Invalid Date Error while adding new patient

I am trying to add a new patient using postman, I am getting this error:

"validationErrors": {

    "DOB": {

        "DateTime::INVALID_VALUE": "Date of Birth must be a valid date"



"internalErrors": [],

"data": []


my json:

“title”: “Mr”,

“fname”: “Foo”,

“mname”: “”,

“lname”: “Bar”,

“street”: “456 Tree Lane”,

“postal_code”: “08642”,

“city”: “FooTown”,

“state”: “FL”,

“country_code”: “US”,

“phone_contact”: “123-456-7890”,

“DOB”: “2023-01-30”,

“sex”: “Male”,

“race”: “”,

“ethnicity”: “”


According to the error, your date is invalid.

Date is not supposed to be a String.

it should be:

DOB: 2023-01-30

without the double quote.

So the DOB should come in as a string, removing the quotes will create an invalid JSON.

This is the line that does the DOB validator

Just eyeballing it, I can’t see what’s wrong with your date format. You may have to put a breakpoint in on a local box and try to step through the code and figure out what is going on as from what I can see it looks like “2023-01-30” should work just fine for the DOB.

It doesn’t work. Could you help me figure it out?

Hi @stephenwaite @brady.miller @adunsulag I have fixed this. I also have managed to get the SSL.
Now when I use https://182.xx.xx.xx/openemr it gives me the login page and I can get through it. Like shown here:

But when I try to register an API client through postman I get a 404 error.

Please help. This is urgent!!!
Also, I have tried keeping the URL in admin>global>connectors as https://localhost as well. Doesn’t work

So are you able to register a client on the OpenEMR demo servers?

Have you checked that your apache mod_rewrite is enabled (which is what is used to map the /oauth2/default/registration to the /oauth2/authorize.php file.

Is Postman able to hit the main OpenEMR login page and retrieve a result?

If you have something time sensitive you may want to consider reaching out to an OpenEMR vendor to pay someone to expedite resolving your issues.

apache mod_rewrite was not enabled. Now it is working fine. Thank you for your help. Please help me with the date thing as well @adunsulag