Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Increase the limit size of files in documents

OpenEMR 5.0.5 (5) under xampp in win 10
Hi, When I want to upload a zip file with dicom images in a folder that I made to put image studies, it gives me a maximum of 256 mb, how can I modify it? Probe from php.ini, /openemr/public/assets/dropzone/dist/dropzone-amd-module.js and /openemr/public/assets/dropzone/dist/dropzone.js but I still get the same error.
thanks for your help
regards

hi @mlobo4370, it’s most likely to be php.ini

Thanks for your comment. As I already explained, I tried both modifying the php.ini and with the other 2 files and I can’t increase the limit.
Regards

does phpinfo() show what you set it at?

I put max file size in 512mb post and memory too

What’s the zipped file and unzipped file size?
This probably has to do with dicom view file size limit!

also, max set upload size for drop or file upload in openemr is 64MB.
If getting error from the upload then it’s a apache max file size problem. If errors loading in viewer then it’s viewer issue!
If folder upload, I didn’t put limit so, no idea.

the compressed file weighs 269 mb and it tells me that the max allowed is 256 mb

This is uploading via Folder uploader, right?
also, did you restart server after php.ini changes?

Through the folder loader it does not give any message but it does not load them. using dropbox it gives the error of maximum size 256 mb. of course with each modification I restart apache

Okay I don’t understand. Are you uploading the zip or loading a folder where we zip the files or both?

I’m uploading a zip file. I have tried both by file explorer and by dropfile

You can take a look here: controllers/C_Document.class.php around L-240 on v6 but should be close by in v5
I don’t have a large enough zip of dicom study to test so on you.

Don’t work. I changed in the line 256 by 512 and not work

@mlobo4370
OpenEMR has a 64MB limit on file uploads. You know where to change those in source to 640MB or so.
For a dicom zip, we open the zip to inspect so that will use memory. For folder uploads where no one file size in folder exceeds 64MB, then your only limitation will be the max number of files and the max input variables allowed by PHP via php.ini.

So if you have a folder of 1130 files then you’d need at least that many file handles and input variables set in php.ini. For minimums:

  • upload_max_filesize = 640M
  • max_file_uploads = 2000
  • max_input_vars = 2000

This may get the file(s) uploaded but now we’ll hit browser and viewer limitations. As of now and the best I can tell is, we’ll start failing around 240 slices loaded into viewer which is approx. 128MB!

So I don’t know if am clever enough to get around this but will spend some time on this when I update some dependencies and work on PACS.

when I upload the zipped files is it the same? the warning says greater than 256 mb

Another option could be to divide them into 2 or 3 zip?

Regards

Need to add this to php.ini. I was able to upload by zip and folder the study you sent me. I tested on both xampp and linux.
Somehow the viewer loader is going to need to cache or find a better way to deal with large studies.
I don’t have time to devote to this just now however, maybe you can track down a solution and contribute back…

thank’s

My default values are :

  • upload_max_filesize = 40M
  • max_file_uploads = 20
  • max_input_vars = 3000

Again, you need to change your defaults if you want to upload large zips or folders Make them like this:

  • upload_max_filesize = 640M
  • max_file_uploads = 2000