Immunization reports are not generated at reports by entering CVX code for the patient

question

(marimuthu) #1

Hello Devs,

Actually I’m facing an issue when entering CVX code text.

In frame layout settings,
First I’ve selected a patient and filled immunization report in the patient’s page.
Then I moved to Reports -> Clients -> clinical option. By submit, we can see all the immunization entered for all patients. But when I tried to give cvx code text like “measles virus vaccine” in the “Immunization” text box, I can’t see any filtered patients below.

In online demo, its working good.

I’ve installed openemr 5.0.1 in my local system. I’m using ubuntu 16.04 os and mozilla/google browsers.
But its not filtering any patient below when we give the same cvx code in this page.

In demo only,its working good.When installed in my local system, its not working.

I’m expecting developers help.

Regards
Marimuthu
Software Developer


(Jerry P) #2

When reporting these issue it is much easier for us/me if you also check for php errors and javascript errors reported in console.
Also strange it works on demo and not local. I can’t readily see how the calendar patch would cause this issue.


(marimuthu) #3

Hello Mr.Jerry

Thanks for your reply again.

I found this error in terminal Ubuntu.
" PHP Fatal error: require_once(): Failed opening required ‘…/globals.php’ (include_path=’.:/usr/share/php’) in /var/www/html/openemr/interface/reports/clinical_reports.php on line 13 "

Is this the actual error for not displaying immunization report with cvx codes?

I’m using php7-fpm version currently.

When you install openemr from this link https://www.open-emr.org/wiki/index.php/OpenEMR_Downloads under Linux tar ball package.

Regards
Marimuthu
Software Developer


(Jerry P) #4

It’s in the right area but it surprises me. Will take a look…


(Jerry P) #5

Try changing for globals.php openemr/interface/reports/clinical_reports.php line 13 to:
require_once(dirname(__FILE__) . "/../globals.php");
Your php error would cause the page not to load so if it is loading and the search term is not working i’d expect it not to work on demo also.
Also check the menu item About for patch level you are using with our current being 7. https://www.open-emr.org/wiki/index.php/OpenEMR_Patches

Otherwise, this works for me and don’t see why FPM would be any different however I am testing on windows but, still.


(Brady Miller) #6

Hi @marimuthu ,
What are the details of your environment. Are you using apache or nginx to connect to php7-fpm? Are dockers involved?
-brady


(marimuthu) #7

Hello Mr.Miller

I’m using openemr 5.0.1 with ubuntu 16.04 os, nginx server and php7-fpm.
There is no docker.

Regards
Marimuthu
Software Developer


(marimuthu) #8

I tried here but not working.
I’ve checked the patch menu item. But the clinical_reports.php file was’t there in the list.

Could you help me soon…

Regards
Marimuthu
Software Developer


(marimuthu) #9

Hello Mr.Jerry,

Last week I asked you a help about the immunization portion issue.
Could you help me…

Regards
Marimuthu
Software Developer