Image Canvas Does Not Save in LBF


(Erik Pampalone) #1

I created a Layout Based Form that uses the Image Canvas. The functionality allows me to place an image in the Image Canvas and draw on the image, which is great.

I can bring the form up and draw on it in the Encounter, which is expected.

When I click Save, a warning pops up (This page is asking you to confirm that you want to leave - data you have entered may not be saved).
image

If I choose to continue (Leave Page), the next page shows the form text, but does not capture the image.
image

And the print out does not capture the image either.

Any thoughts on what I could do to capture the image when saving the form?

-Erik


(Erik Pampalone) #2

Hi @sunsetsystems,

Can you tell me if I am implementing the Image Capture functionality correctly on the LBF? I would like to capture the image after I draw on it, but don’t see it after I attempt to save it.

-Erik


(Rod Roark) #3

Save should not cause that error. Sounds like some javascript on that page is broken.


(Rod Roark) #4

Suggestion: Try it with a layout that just has your image canvas on it and nothing else, and see if you still get the stay-or-leave message. If not, add the other fields one at a time until the message occurs. That will help to narrow it down.

Also which OpenEMR version is this?


(Erik Pampalone) #5

Thanks Rod @sunsetsystems,

Thanks for suggesting starting simple. Makes sense.

I am using v5.0.1 (6)

I did a bit of troubleshooting. Here’s what I found. If there is an image included it gives me this error.

I tried it with a few different size images, just to make sure.
image
image
image
image

Then I removed the image from the form.

I then drew on the blank Image Canvas and saved it, but nothing showed up.

I will do some more digging, but if you have some additional suggestion I am listening.

-Erik


(Rod Roark) #6

Perhaps the image is too big for your php.ini settings. Check post_max_size and upload_max_filesize in whatever php.ini file your web server is using. After fixing these be sure to restart the web server.