I have an Error in Adding top level in procedures configuration. I need help please

Please specify version and server information, php version etc

Version OpenEMR
J’utilise OpenEMR version 6

J’utilise: Microsoft Edge

Système d’exploitation
J’utilise: Windows

PHP version? XAMPP?

Also firefox is better for opener

Xampp for Windows 8.1.2 (64bit)
PHP 8.1.2
I have the same error Whith Firefox

Openemr is compatible with up to php8.0
I wonder if that is the problem?
If I’m not mistaken, you might be able to use XAMPP with another version of php

But I have already set up OpenEMR by changing the php version, I won’t risk losing my data?

Well, backup your data first, and make a backup of the documents directory, which should be located at:


However, no, as far as I know, you should not lose your data.

the download page, states that it should work up to php 8.1

I stand corrected! Thanks for the clarification.

@BADOLOMadinatou Have you tried to do the same in the demo?

Yes, but I have the same error

I still haven’t got a solution

@BADOLOMadinatou , can you detail the steps you’ve taken that leads to this error?

If the demo has the same error, it may be a bug.
Can you tell me what you did?

I am assuming:
Procedures → Configuration, then what?

Procédure → configuration and the error message appears.

Also when I do
Patient → visits → current → clinical-> procedure order , after filling on allait the items when I backup I have the following error message :
Fatal error: Uncaught mysqli_sql_exception: Unknown column ‘pd.cmsportal_login’ in ‘field list’ in C:\xampp\htdocs\openemr\vendor\adodb\adodb-php\drivers\adodb-mysqli.inc.php:788 Stack trace: #0 C:\xampp\htdocs\openemr\vendor\adodb\adodb-php\drivers\adodb-mysqli.inc.php(788): mysqli_query(Object(mysqli), ‘SELECT po.proce…’, 0) #1 C:\xampp\htdocs\openemr\vendor\adodb\adodb-php\adodb.inc.php(1263): ADODB_mysqli->_query(‘SELECT po.proce…’, false) #2 C:\xampp\htdocs\openemr\vendor\adodb\adodb-php\adodb.inc.php(1217): ADOConnection->_Execute(‘SELECT po.proce…’) #3 C:\xampp\htdocs\openemr\library\ADODB_mysqli_log.php(27): ADOConnection->Execute(‘SELECT po.proce…’, Array) #4 C:\xampp\htdocs\openemr\library\sql.inc(283): ADODB_mysqli_log->Execute(‘SELECT po.proce…’, Array) #5 C:\xampp\htdocs\openemr\interface\orders\single_order_results.inc.php(341): sqlQuery(‘SELECT po.proce…’, Array) #6 C:\xampp\htdocs\openemr\interface\forms\procedure_order\report.php(20): generate_order_report(‘16’) #7 C:\xampp\htdocs\openemr\interface\patient_file\encounter\forms.php(1103): procedure_order_report(1, 5, 2, ‘16’) #8 {main} thrown in C:\xampp\htdocs\openemr\vendor\adodb\adodb-php\drivers\adodb-mysqli.inc.php on line 788

Not able to reproduce in the demos, you probably need to add the field cmsportal_login back to the patient_data table if it was removed somehow.

the solution was to disable « Enfonce E mail in portal log On Dialog » in Administration → globals → portal.
Now a can add a procedure order but when a go to Patient → patients → select patient and procedures → pending review I have no thing