How to turn off 2FA?

I have access to two admin users on somebody else’s system and I find that one of them has had 2FA turned on. Problem is, I do not have the mobile device that receives the OTP code so I can’t log in as that user to turn it off.
Is it possible for me to turn off 2FA on this user?

Hi @htuck ,
You could try logging into Openemr with your admin credentials and navigate to the MFA management option below the administrative settings on the top right corner. You could try turning off the 2FA from that settings.
If you have further queries ,drop a mail to

-ViSolve AI Team (AS)

Hi Visolve-
Thanks for your prompt respponse.
If you mean the settings menu shown here under the user’s name, I can only see that it offers access to the logged- in user’s MFA settings, not to any other user’s. Were you referring to some other menu?
Best- Harley

hi @htuck , there’s no way in the GUI. Have to run a sql statement on login_mfa_registrations

Hi @stephenwaite
Ah, that’s a good thing to know- maybe I can put it in some wiki doc on the topic.
Fortunately for me that other system happens to have adminer installed so I should be able to fix things!
And… looking in table ‘login_mfa_registrations’, I see that a usr who has MFA is listed; usrs who do not have it are not present in the table.
Does that mean that to turn off MFA for a usr you need to delete that row?

  • HT
1 Like

hi @htuck , yes, that will do it.

1 Like

—Aaaaannnddd-- yes it did!
Thanks v much @stephenwaite !

  • HT