How do I avoid generating HL7 file for transmission to an external lab


(Richard Karinguri) #1

Situation
Hello folks. My clinic has an internal laboratory and therefore do not was to transmit any order to any external laboratory. I find it annoying to download HL7 file every time I click on on ‘Save and Transmit’. Is there a way I can avoid this? Kindly help. Regards.

OpenEMR Version
I’m using OpenEMR version 5.0.0

Browser:
Google Chrome

Operating System
Windows 10


(Jerry P) #2

You could try configuring Procedure Provider with Local file system then add a directory to sites/default to save the orders.
re: or even save to systems temp directory if hl7 message is not needed


(Richard Karinguri) #3

@sjpadgett how do you do that? Where do I need to go? I have been unable to proceed from the point I have circled in the screenshot below. Thanks.


(Jerry P) #4

Give this a try:
Go to menu Procedures->Providers

  • Select your internal lab.
  • Set Usage: to Production.
  • Change Protocol to Local Filesystem. Not sure about using Results Only but try.
  • Add C:\Windows\Temp to Orders Path:.
  • Save and be free …

Since Window will manage cleaning up your Temp directory, all is well if, you are not sending or using the hl7 message for anything. There is not a need for Login, Password e.t.c.


(Jerry P) #5

@Quantice Hi, If this proved to resolve your issue would you please mark as solution for other’s that may be searching forum for similar issues. Thanks.


(Richard Karinguri) #6

Hello @sjpadgett I apologize for not giving timely feedback, it is because I have been away from OpenEMR. I tried the above solution as suggested, the Hi7 did not download after clicking save and transmit but instead I got this error "Transmit failed: Cannot create file “C:\Windows\Temp/19.txt”
Kindly find a screenshot of what I did as per you instruction. Regards


(Jerry P) #7

You need to find a writable temp system directory somewhere to throw away the download. You can try:
\xampp\htdocs\openemr\sites\default\documents\temp if your domain path is xampp/htdocs/openemr or any system temp directory. Path I gave you works on my windows 10 but I have UAC turned off…


(Richard Karinguri) #8

@sjpadgett thanks for timely reply. My OpenEMR is hosted in a shared remote server not XAMPP. Do you have suggestion for this? Regards


(Jerry P) #9

Give this path a try:
./…/…/…/sites/default/documents/temp


(Richard Karinguri) #10

@sjpadgett it worked well for me thank you.