Hosted OpenEMR: Unable to install Open EMR application on a hosted Environment

installation

(Nelson Nyabera) #1

Situation
I need you help in regards to the subject matter. I have been trying to install OpenEMR since yesterday but till now, I have not succeeded.
Each and everytime I try, I am getting beelow error at stage 3. Connecting to MSQL…Error. Check your login credentials. Unable to connect to the database as user ‘Vijaiqqx_openemr’

I have successfully created the database ‘Vijaiqqx_openemr’ and added user ‘Vijaiqqx_openemr’

When installing the app, I am using the option of “I have already created the database” at stage two.

OpenEMR Version
I’m using OpenEMR version 5.0.1

Browser:
I’m using: Latest Chrome and Firefox browsers.

Operating System
I’m using: Cpanel hosted services

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability

I need your urgent help.


(Nelson Nyabera) #2

Below are my database Configs as shown below. I have tried replacing server hostname with IP address but I am still getting the same error.


(Jim Chan) #3

I’ve not installed OpenEMR on Linux before but I looked up the installation instructions for 5.0.1. It look like during step 2 is where you define your configuration preferences such as database name, database username, etc. During step 3 is where the database is actually created. Any chance this is your second attempt at installing?


(Asher Densmore-Lynn) #4

MySQL credentials and database names are case-sensitive. If you created ‘V…’ and tried to log in with ‘v…’ this would happen.


(Nelson Nyabera) #5

Hello Asher,

You have managed to do this on a shared hosted Cpanel or on a local host? Did you use the host name or the IP address on step 2?


(Asher Densmore-Lynn) #6

Sorry, I’ve never worked with cpanel before. I only posted to point out that as quoted, you were mixing case between your created user and your setup-provided user.


(Nelson Nyabera) #7

Hii Guys,

I have managed to fix the issue!. The information on guideline is kinda miss leading abit. If you are using Hosted services, then you dont need to replace the server host with the IP address. It Should remain local host. This was the major issue that was causing the error!!!

Thanks.