Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Help Needed for Centos 8 OpenEmr setup_statr, session

Situation
Hey,guys Im trying to set up openemr for practice. our cybersecurity team is competing in the southeast regionals in the first week of april and one of out task is using the service of openemr. Ive run in to a problem which i cant figure out a solution after initial login and set theme page it shoots me this error
Warning: session_start(): open(/var/lib/php/session/sess_kzgB0HCPOgWX4tOQwbmW9A0QIUILU80zbQFpTh2vPlg8-dCF, O_RDWR) failed: Permission denied (13) in /var/www/html/openemr/src/Common/Session/SessionUtil.php on line 78

Warning: session_start(): Failed to read session data: files (path: /var/lib/php/session) in /var/www/html/openemr/src/Common/Session/SessionUtil.php on line 78

Ive read alot of places where I need to set up the path in PHP,ini and so i changed the aboluste path in the sessions.save_path varible = /var/tmp/
i also tried saving it to /var/lib/php/sessions

another solution i tried was decreasing the timeout for cache

and using chown to on the sessions directory all attempts were futile
I need Help please!

OpenEMR Version
I’m using OpenEMR version 5.0.2

Browser:
I’m using: firefox

Operating System
I’m using: Centos 8

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks () for readability [27-Mar-2020 19:54:17 UTC] PHP Warning: session_start(): open(/var/lib/php/session/sess_Yib1rERaDismIDQsOHMXbdzxdtYTxEzkFxGYafDDUSplJtP-, O_RDWR) failed: Permission denied (13) in /var/www/html/openemr/src/Common/Session/SessionUtil.php on line 78 [27-Mar-2020 19:54:17 UTC] PHP Warning: session_start(): Failed to read session data: files (path: /var/lib/php/session) in /var/www/html/openemr/src/Common/Session/SessionUtil.php on line 78```

Did you install apache ssl/tls module (mod_ssl)?

i did try downloading the mod_ssl

I had the same problem in Centos 8 and it was because of that mod. I edited the /etc/httpd/conf.d/ssl-params.conf file as follow:


And it worked.

Should I create the ssl-params.conf? I dont have that conf file i that directory i only have

No, don’t create it. That directory is created when you install ssl-mod.
I do not know what it could be. The The folder group /var/lib/php/session must be to apache Have you tried disabling Selinux?

yes Ive disabled selinux. thank you for your help btw.