Growth charts don't show data after upgrade to 7.0.0

I recently upgraded to version 7.0.0(2) and found that the growth charts don’t work. The image will be generated and the patient name is on the chart but no data is listed or plotted on the chart. Has anyone else had this issue?
I’m running version 7.0.0(2) on Ubuntu 22.04.1 LTS, PHP 7.4.3, and MariaDB 10.3.37.

Turn User Debug on in Config Logging.
See what happens.
I highly recm upgrade PHP 8.1 or 2.

I don’t see any change or errors in the main log. When I look in the error.log from apache, it shows errors from the pdf creation program that indicates it doesn’t have any data passed to it. I will work on updating PHP.

for openemr 7.0.0 php → 8.0 would be a safer upgrade

OK, I will try version 8.0 and see if that helps. Thanks!

growth charts are working at OpenEMR Login running openemr, php 8.0.13

PHP 8.0 was troublesome and is why they released 8.1 so quickly.

1 Like

When I click on Growth Chart (PDF) under the Vitals list I get the following error:
Fatal error : Uncaught TypeError: Unsupported operand types: string / string in /var/www/ Stack trace: #0 {main} thrown in /var/www/ on line 637

If I click on Growth Chart (PDF) under Vitals History, nothing happens.

Could you upload your chart.php script please?

chart.php (30.1 KB)

1 Like

try this chart.php (30.1 KB) which has a fix for when the weight or height is empty

Thank you, that fixed the error, so that pushing the Growth Chart (PDF) or Growth Chart (HTML) brings up a chart with the patient’s name, but no data, no matter how much data is in the patient’s file. However, the error message is gone. I don’t know if it is related, but when I click the link to graph the data from the vitals section of the dashboard, it always says there is too little data to graph, no matter how much data is in the patient file.

Ok, something must have broken with a prior commit, will review and post back here.

Stephen that’s what I am also facing when I copied the code from the prior post. Looking forward to the corrected code. Thanks for your help!

hi @Jit_Chawla, the above PR now prevents the growth-chart print buttons from showing up when accessing the trend form from the dashboard. The only way to get a good print of the chart is to edit the vitals inside the encounter.

hi, have a fix up that’s plotting multiple points and should be able to get this in the next release :slight_smile:

Thanks Stephen but I tried this fix and got this error. On windows AWS and checked the file property permissions put them to read/write and still no resolution.

Fatal error: Uncaught Error: Failed opening required ‘C:/xampp/htdocs/openemr/library/’ (include_path=‘C:\xampp\htdocs\openemr\vendor/pear/archive_tar;C:\xampp\htdocs\openemr\vendor/pear/console_getopt;C:\xampp\htdocs\openemr\vendor/pear/pear-core-minimal/src;C:\xampp\htdocs\openemr\vendor/pear/pear_exception;C:\xampp\php\PEAR’) in C:\xampp\htdocs\openemr\interface\forms\vitals\C_FormVitals.class.php:13 Stack trace: #0 C:\xampp\htdocs\openemr\interface\forms\vitals\new.php(15): require_once() #1 C:\xampp\htdocs\openemr\interface\patient_file\encounter\trend_form.php(170): include_once(‘C:\xampp\htdocs…’) #2 {main} thrown in C:\xampp\htdocs\openemr\interface\forms\vitals\C_FormVitals.class.php on line 13

Any help from anyone, greatly appreciated !

hi @Jit_Chawla , thanks for letting me know, probably easiest to wait for the soon to be released version 7.0.1 which fixes the issue.