Google Two Factor Authentication


(visolve) #1

ViSolve has completed integrating Google Two Factor Authentication for OpenEMR with Google Authenticator.

This is easy to install even with an already deployed OpenEMR system!

If you want to play with it please send mail to services@visolve.com
-ViSolve OpenEMR support team


(Chrys Ostrander) #2

Hello,

I’m trying to use OpenEMR 5.0.2 that I just finished installing. I can’t get past the login screen using the credentials I entered during setup. I tried the solution using the hash to enable ‘pass’ as the admin password, but it still will not let me in. I think it might be related to the two-factor authentication I did opt for during set up. The instructions said I should have my phone ready for the QR code, and I did. It said the QR code would be “next,” but no QR code ever appeared. It just went on its merry way and finished installing OpenEMR. I am thinking it wants something from me at login that I don’t have. Is there a way to disable two-factor authentication in the database?


(Brady Miller) #3

Hi @Chrys_Ostrander ,

Sounds like a bug in setup. So we can test it, what is your operating system?

To fix your issue, just remove the entry for your user (should be the only entry there) in the login_mfa_registrations sql table.

You can then set up mfa for the user within OpenEMR per these instructions:
Documentation for Multi-Factor Authentication?

-brady


(Chrys Ostrander) #4

Thanks for the fast response. I’ll try that. System is:

HP 251-a123wb PC Pentium J2900 4GB RAM 1TB

Ubuntu Server 18.04.3

LAMP (clean install)