Gmail configuration for remminders [fixed]


(jalea real) #1

Hi, I can’t set up gmail account for reminders
Administration>Globals>Notifications


do you know where the problem is?


(Asher Densmore-Lynn) #2

465 is an SSL port, but it doesn’t look like you’ve made any selection for SMTP security.

Additionally, I don’t think your SMTP credentials are right; Google’s usernames are email addresses.

Also, configuration may be required on Google’s side to allow password auth (instead of OAuth).


(ViSolve) #3

Hi @jalea,

Please check here to know how to configure notification module in the OpenEMR.

Make sure that you have allowed the patient to receive the emails (Patient>Demographics>Choices) and listed the following file under cron job:
http://localhost/openemr/modules/sms_email_reminder/cron_email_notification.php

In addition, refer Google’s official documentation for SMTP settings to send email.

Thanks,
ViSolve


(jalea real) #4

fixed
thanks


(Jerry P) #5

I’m not sure which port the mail is sent through but ensure that port is turned on in your router config. That catch folks many times.


(Jerry P) #6

Just wanted to add a note here for others, though this was fixed using port 587 and TLS if you are running SSL it is preferable to use port 465 and SSL authentication. Also best to setup a separate app password specific for openemr app on the google account and name it something like reminders or oeNotify etc…