Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Fee sheet problem

I’ve been trying to get my ducks in a row prior to upgrading from 5.0.2(4) to 6.0.0 when I noticed an irritating problem. I have a backup server (Ubuntu 18.04 Server) upon which I have an instance of OEMR 5.0.2(4). It runs perfectly and can be accessed without problems from my network by my Mac (Mac OS Big Sur) with either Safari or Firefox. However, when I back up this server and transfer the backup file and install it on my experimental virtual server (on the Mac, but running Ubuntu 20.04 Server) I get a different behavior. If I create an encounter and then a charge (using the Fee Sheet) through Safari I get the expected behavior (see attachment safari_fee_sheet). But, if I do the same thing through Firefox the Fee Sheet window is somehow corrupted with the underlying buttons not disappearing and the fee options appearing over the top of them, which is visually confusing (see firefox_fee_sheet). I can still check and save them however, so the functionality is there but the presentation is bad. Obviously, the underlying code must be basically OK but is somehow not playing ball with Firefox. Yes, you might notice that I constructed my own fee sheet “select code” options years ago but they have worked with both browsers without a hitch for at least five years. Yet, something has changed, at least for Firefox. Any ideas?

Just to add to the confusion. I can otherwise successfully upgrade to 6.0.0 and the appearance problem is resolved (both Firefox and Safari properly display the procedure selection dialog). Unfortunately, the box is now nonfunctional (cannot click in the checkbox to select a billable procedure) for both browsers.

So you know, i’ve seen this and had in my mind to fix but, got sidetracked.
Will try to have a fix today soon!

that’s a checkbox bug introduced, just click on the highlighted row for now please, or if you’d rather just revert that code for only check box click

That appears to solve my immediate problem but for anyone who’s interested, the highlighted area to the right of the label is what needs to be clicked in order to put a check in the checkbox (at least on my system and on the demo). Thank you.

“the box is now nonfunctional”

move the little hand, over the upper or lower borders of the box, and try to click it. It worked for me