Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Fee sheet issue on 6.0.0 under Linux

EMR ver 6.0.0
OS Linux Ubuntu 20.04.2 LTS
JVM installed on the system
Problem:
Fee sheet buttons do not work. When I click on the Established patient button, the check boxes with the categories appear. When I try to check a box, nothing happens.
The same function works well under Windows 10 at 6.0.0 version installation
Any suggestions?

hi @vik, oh, it’s a known bug

Didn’t you do a fix? Thought I saw a PR.

no, couldn’t decipher the knockout

actually think it works easier without having to get into that little checkbox :slight_smile:

Agreed but I had that working with click on label in v5.0.2. I don’t understand how knockout got involved.
As now there is an event conflict.
Is your PR still up?

Hey, if you want to have some fun, try replacing fancy box with dlgopen! tedious…

1 Like

I just checked and my code_choices.php file line 33 looks exactly like you recoemmend -


It is still not working for me.

hi @vik, you can’t click on a highlighted row?

oh yeah, click on label, but we want the full monty :slight_smile:

I clicked on the highlighted raw. I also opened my the code_choice.php file on my server and verifies that the line 33 is similar to the line 33 highlighted in green. It is still not working.

not sure if clearing your cache helps?

Thank you so much. Restarted the server and it is working!
Appreciate your help!

1 Like

I’m going to look at because Brady may work on patch this weekend.(his most favorite this to do. :slight_smile: ) so the full monty is being able to click label or box, correct?

ok, thank you @sjpadgett, click label, box or highlighted row

It is not working with clicking the box but with clicking on the row it does.


PR next and will be in patch one.

1 Like