Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

FAX SMS - a new wrinkle

   Problem 1
     - openemr/openemr is present at version 1.0.0+no-version-set and cannot be modified by Composer
     - openemr/openemr 1.0.0+no-version-set conflicts with openemr/oe-module-faxsms v2.2.0-beta.
     - Root composer.json requires openemr/oe-module-faxsms 2.2.0-beta -> satisfiable by openemr/oe-module-faxsms[v2.2.0-beta].

This what I am getting. I have not been able to figure out what to do?

for v6(1) composer require “openemr/oe-module-faxsms:2.2.0”
I posted a notice of this release somewhere. Didn’t we just go through this and you were working?

New install, new person have issue. The other is working fine.
I get that message running composer require “openemr/oe-module-faxsms:2.2.0”.

Ya should never install composer under root. faxsms is not meant to run there anyway.
You probably could do sudo composer require openemr/oe-module-faxsms:2.2.0 to install however, openemr shouldn’t be in root, faxsms same…

Uninstall composer from root and reinstall elevated to same level as your other user group. One that may have www-data etc.

You may need to cleanup your home directory composer stuff or there may be a way to to fix the way installed now. Web search it…
Hang in there…

  • openemr/openemr is present at version 1.0.0+no-version-set and cannot be modified by Composer

Does anyone know what this mean? Where is composer looking to get this information? I checked the composer.json file and there is nothing in there about the 1.1.0 version.

I wish I had your server.

Did you not read my previous reply? Get composer out of root…

I did exactly what you said. I installed composer. I reinstalled composer. I can run composer without using sudo. Look again, it is not in root. The command line starts with ubuntu@ip…

easier to call me. i’m only typing with one hand these days. hard!

1 Like

New findings. I downgraded the composer from 2.0.11 to 1.10.20 I was able to install the module.

composer diagnose

composer upgrade --1 (this is to downgrade from 2.x)