Enable messaging in ACL without being a Superuser


(Philip Herrick) #1

I want Clinicians to be able to use the Message function but the only way I can see to enable it is to give them Superuser status. This enables all the administration rights - and I don’t want Clinicians to get that.

Is there an ACL setting that enables Messaging that is not Superuser?

OpenEMR Version
I’m using OpenEMR version 5.0.2

Browser:
I’m using: Chrome

Operating System
I’m using: AWS EC2 and local machine is a Macbook

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability


(Stephen Waite) #2

hi @Phil, clinicians can send messages on the demo of 5.0.2 with the default ACL


(Philip Herrick) #3

Hi @stephenwaite, I’ve checked the demo site and neither clinicians or physicians can send messages with the current ACL settings. When you open the message screen on the demo site, click “New Message” and as soon as you check any field, eg Type, you go to a 404 not found page.

When I go in as Admin, make them a Superuser, go back in as clinician and then they can message. We need to identify if the only way you can message is to be a Superuser.


(Stephen Waite) #4

hi @Phil, can’t reproduce here: https://six.openemr.io/c/openemr/interface/login/login.php?site=default

username: clinician
password: clinician

click on Messages and then

+ Add New

it’s possible you need to clear your browser’s cache


(Philip Herrick) #5

Hi @stephenwaite, thanks for that. Yes, the link you sent works fine for me too. I copied the settings to my site but, sadly, still no luck.
Cleared the cache, restarted the AWS instance. The only way I get get messaging to work is by making the clinician a Superuser.
This might have to go in the too hard basket.