Development docker update images in order to get Patient Portal to work


(Stephen Nielson) #1

So I throw this out there as a helpful hint for others who are running into problems logging into the patient portal who are running on the flex docker image for openemr.

If you are having problems logging into the patient portal and you are working against the docker flex image make sure you update your docker images to resolve this login issue. You can run the following command:

docker pull openemr/openemr:flex

This will update your docker image to the latest server code fixing the login problem against the latest codebase. The daily built demos currently have this problem (I’m not sure they run against the latest docker flex images).

I personally destroyed my volumes to make sure everything was a clean slate and then started them again, but you may not have to do that:

docker-compose down -v
docker-compose up

Apparently there was a bug in the docker images that was setting the apache php’s session.cookie_path to be /var/www/localhost/openemr/ which would never resolve as that path is a file system path and not a browser URL. This made it so the patient portal would never login as the cookie value that was stored would never get sent up. It looks like @brady.miller fixed this in the latest docker images. I wanted to give people a heads up though as its not something you would typically check to do (I know I wasn’t looking for it).


(Brady Miller) #2

hi @adunsulag ,

This is a really good point. When I update this docker (am going to do another one soon to allow DELETE requests for the api), I should announce it somewhere. I’ll start announcing it on a forum thread. (as an aside, the nice thing about these flex dockers is they use same apache/php configuration and docker environment as the official dockers, so bugs/fixes on these apply to and make the official dockers better and more robust)

-brady