Can't see Docker container

I am investigating using OpenEMR as a customizable solution for a client’s rather esoteric healthcare practice.

As an initial dev version, I’m running on a local Ubuntu server VirtualBox VM. I have successfully downloaded and installed the Docker package (using the lightsail script from here: openemr-devops/packages/lightsail at master · openemr/openemr-devops · GitHub) and got up and running within two minutes. I can access the site at http://<ipaddress>/interface/main/tabs/main.php, I can create patients and appointments - everything seems to be functional. However, on the server I can’t for the life of me figure out how to stop/restart/modify anything having to do with the container or webapp in general.

Running docker ps comes up blank and docker ps -a only shows the “hello-world” container I ran as part of the docker install/test process. Running docker service ls also returns nothing as does docker container ls. The only thing I can figure out that shows what is running is docker-compose config --services, which returns mysql openemr phpmyadmin

Furthermore, docker-compose down does not seem to actually take down anything - I can still get to the app fine via the browser.

As I said, I’m interested in customizing the app (images, etc.) and eventually modifying the code to add some other features. I’m starting to think forgetting about Docker and just installing the barebones app might be the way to go. But I still need to know how to actually take down the container/services so that I don’t have conflicting versions running.

Thanks for any pointers. I’m new to Docker, but not web development in general.

You’re not running that docker ps command from the same place the script is running. Maybe you’re in another instance, maybe you’ve got multiple virtual machines running, but you can’t hide running containers from docker ps. I’d start killing instances and seeing whether or not OpenEMR goes away.

You were exactly right. For some reason I had two dockerd processes running. Killed them both and the site went away, as expected. But now I’m having trouble getting it back. Ran the script again, and it seemed to work the first time, but nothing responds on port 80. Running docker ps only shows openemr/mysql-xtrabackup:latest running. For some reason I can’t get the openemr container to run. Trying to use docker-compose up -d but that doesn’t seem to be working.

Another thing I noticed is that in (Linux’s) top I see about 5 docker-container process running. Could this have something to do with not being able to bring up a new instance?

Okay, I got it back up. Took some fiddling with the containers and killing/restarting the docker service. Then I re-ran the script.

Thanks for your help btw.

Now what’s the best way to get at the “filesystem” the openemr container is using? Is there a dev guide somewhere? I’m basically interested in changing the images/logos for now.

openemr-devops/packages/lightsail at master · openemr/openemr-devops · GitHub discusses how to get access to the container volumes.