Cannot find version 5.7.41 for mysql - OpenEMR Cloud Standard Edition - CloudFormation Issue

OpenEMR Version
I’m (attempting) using OpenEMR version 7.0.2 (latest version at time of writing)

I am attempting to deploy OpenEMR Cloud Standard Edition in my AWS account from the marketplace listing: Amazon Web Services Sign-In

When I launch the stack creation, I recieve the following error:

Resource handler returned message: "Cannot find version 5.7.41 for mysql (Service: Rds, Status Code: 400, Request ID: 3f1c0225-a3df-4831-b3b2-ede4d44bbecc)" (RequestToken: ab87cd60-3426-a576-1306-1a39b420c1a0, HandlerErrorCode: InvalidRequest)

It seems that mySQL version 5.7 is only available through RDS Extended Edition since its official AWS RDS support has ended: MySQL on Amazon RDS versions - Amazon Relational Database Service

Has OpenEMR been proven to work with MySQL 8.0? If so then I would assume this is an easy fix.

Honestly, I would prefer to use MariaDB (assuming PostgreSQL is not yet supported), if someone has a CloudFormation Template using MariaDB that would be ideal for my purposes

Or maybe I am missing something obvious?

Huge Thank You!


I ran into the same problem today. Looking at the cloudformation template, upgrading to MySQL 8.0 may require rebuilding AMIs. Can an expert please chime in?

OpenEMR wiki recommends MariaDB over MySQL.

1 Like

hi @Goddard and @cpnsider , thanks for reporting here. Started a new issue. For the mariadb feature request, feel free to start another issue on devops :slight_smile:

1 Like

I can’t fix that this minute but as soon as I’m not knocked over I’ll try to get a revised CF template into Amazon.

In the meantime I bet you could just edit the template you got from AWS Marketplace and launch that, which isn’t an ideal answer but it’d get you moving.

Sorry for the trouble!


Thank you so much, you are an absolute life-saver! :heart_decoration: :heart_decoration: :heart_decoration:

1 Like

Hi, was this issue resolved? I’m getting a very similar error: Resource handler returned message: "Cannot find version 5.7.41 for mysql (Service: Rds, Status Code: 400, Request ID: d8b500fb-b3c9-4e5e-8391-36460911efb4)" (RequestToken: 4fea68cc-14da-8832-6107-6cccb24a8aa6, HandlerErrorCode: InvalidRequest) Thanks for your help!

Not yet, sorry. I’m starting work on a task list right and that’s on it but it won’t be done immediately.

Very Much Appreciated! Thank you! :heart_decoration: @jesdynf

How can this be resolved? I am receiving the same error. I am looking forward to roll out the standard install.

1 Like

I am also still experiencing this error when attempting to setup from the AWS Marketplace Console.

I also attempted to setup directly from the cloudformation template which has lead me to a separate issue: Cloud Standard Deployment - Received FAILURE signal with UniqueId

(Again, huge thanks for anyone taking the time to read this & extra special thanks to @jesdynf for the ongoing support)

If you’re still getting the 5.7.41 you don’t have the newest copy of the template, I don’t think. Is there a way to upgrade your version? Last week’s upgrade was supposed to have gone through already.

Aw, c’mon.

I spotted the problem, it was on Marketplace’s side. The procedure for products provisioned with CFTs is a little manual and they got something wrong when they did their edits, I think. I’ve sent them a note about it and hopefully it’ll be repaired soon.

Sorry about that!

1 Like

Thanks so much! You’re continued support is greatly appreciated @jesdynf !

It only works if you are using Tokyo when using the template from Github. All other locations use non-existing ami templates. I have OpenEMR in the AWS Tokyo datacenter now but the delay is too high.

Thank you so much for your tremendous work and ongoing support!

1 Like

It’s because they did a hand-edit on their copy of the mappings – but you can do the same. Download the CloudFormation template and open it up locally and you’ll see where the MySQL versions are set. Change your region to an 8.x and you can launch the revised template.

The MySQL versions are all correct now in the template on Github but none of the "OpenEMRMktPlaceAMI exist so the creation of the webserver fails. Do you happen to know the correct AMI ID for one of the USA locations?

“us-east-1”: {
“MySQLVersion”: “8.0.36”,
“OpenEMRMktPlaceAMI”: “ami-07124126f9225d337”
“us-east-2”: {
“MySQLVersion”: “8.0.36”,
“OpenEMRMktPlaceAMI”: “ami-f97f429c”
“us-west-1”: {
“MySQLVersion”: “8.0.36”,
“OpenEMRMktPlaceAMI”: “ami-f5d6c995”
“us-west-2”: {
“MySQLVersion”: “8.0.36”,
“OpenEMRMktPlaceAMI”: “ami-8b4d3af3”

Yes. They’re in the CFT from Amazon. That’s why I said to get the CFT from Amazon.

Get the CFT from Amazon, and edit that to have the correct MySQL version, and you’re good to go.

Amazon’s process changes the AMIs on the document I give them because they distribute the images, which is why what’s in GitHub doesn’t match their final product.

1 Like

It worked!! Thank you so much!
Installing OpenEMR Standard Edition on AWS
Step 1: Select Standard edition template from Marketplace
Step 2: Copy the S3 address of the template into a new browser window and download it
Step 3: Replace all occurrences of 5.7.41 with 8.0.36
Step 4: Create stack from template and upload the template you have just edited
Step 5: Enjoy the most awesome EMR

Great! For the record this shouldn’t be required for very much longer, I’m trying to straighten it out with them right now.

1 Like

Is there any documentation how to create a certbot SSL certificate?