CAMOS PHP Version Warnings

Concerned about Apache Error Log warning that code “will throw an Error in a future version of PHP”. We use CAMOS and need to update from PHP version 7.4, Question is will PHP 8 throw errors?

OpenEMR Version
I’m using OpenEMR version 6.1.0 (1)

I’m using:

Operating System
I’m using: FF 102.0.1

Did you check the logs? Yes
Was there anything pertinent in them? Yes
PHP Warning: Use of undefined constant id - assumed 'id' (this will throw an Error in a future version of PHP) in /var/www/html/openemr/interface/forms/CAMOS/save.php on line 41, referer: https://---/openemr/interface/patient_file/encounter/view_form.php?formname=CAMOS&id=XXXXX

Yes it will throw an error in PHP8.1
I’ll see if I can fix

@hitechelp fix will be in next patch.

Thank you Jerry.
We’ll upgrade to 8.1 after patch 2.