Calendar week view not showing appointments correctly in certain circumstances

The issue I found was this:
If a user is only looking at a single provider’s calendar in week view, and a time slot as more than one appointment in it. Only the first appointment shows up. If you change the view to day, both appointments show up.

What i found was that actually both appointments show up in week view but the “width” and “y offset” in the style did not “split” the view. So the first appointment made covered up the second appointment in that time slot.

I notice in the following files:
The section that calculates the split (about line 450) was different in the week view and the day view. So i copied that part of the day view file and put it in the week view file and it seems to have solved the problem.

I doubt this is anything important. But I’m mentioning it because someone else might have the same problem and want to fix it.

I’m running version 7.0.0(2). Maybe this problem is resolved in the newer versions.

Hi @bearzillasquatch Spoken like a true dev! Not everything is a code issue…

A lot of OpenEMR’s displays will change beyond recognition depending on how big your OpenEMR window is, combined with the zoom factor of the browser. This sounds like one of those cases.
Just expand the window a little and zoom in or out a bit, see if it doesn’t make it right.

If not, then code it into submission! :slight_smile:

Best- Harley

This was an instance where the code was setting the width of the one appointments to 100% when it was supposed to be counting the number of appointments and dividing 100 by the number of appointments and getting the width that way. It was working on the day view but not on the week view.

Anyways, coping the code from the day view to the week view seems to have solved the problem.

Hi @bearzillasquatch
Aaannnd, sometimes it IS a code issue, isn’t it?
Nice catch- HT