Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Calendar issue after 5.0.2. -> 6.0 upgrade please point me to the correct page to correct

Situation
I upgraded our OpenEMR instances this weekend. Completed a backup/restore test between PROD and QA environments, then upgraded QA according to instructions. After review of the QA system we moved on to the PROD environment. Upgraded PROD according to the instructions and everything seems successful except the calendar display.

In the PROD environment, the left hand Calendar view and Providers selection box are both floating over the right-hand providers display. I have tested this behavior in Firefox, Chrome, and Edge (chromium) and experience the same behavior. Of course, the QA environment is displaying it properly.

It seems like a CSS issue because of the floating behavior and the three buttons at the top of the calendar view (hamburger, plus, and search) are showing only the icons without any button styling.

I want to identify the root cause and replicate in my lower environment before messing with PROD. Does someone have an idea what css file I should be looking at?

Dev Tools is showing me a 404 error: Failed to load resource ajax_calendar.css In both QA and PROD the /interface/themes directory has 2 ajax_calendar css files _ie and _sass they appear to be the same in both environments.

OpenEMR Version
I’m using OpenEMR version 6.0

Browser:
I’m using: Edge, Chrome and Firefax

Operating System
I’m using: Ubuntu Server 20.04

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability

This issue is now resolved. I just had to clear my smarty cache.

1 Like