installed openemr 8 on ubuntu desktop 24 mysql 8 , and it takes me literally 2 minutes to log in, from there on everything is slow , my wifi is fast and it is secured https with port 443 open and fire wall on ubuntu open for that channel, any links to trouble shoot it is greatly appreciated , thanks in advance.
My path is /var/www/html/openemr
noticed in installation on linux that the path is /var/www/openemr
is that a problem?
Hi Mohammad, I don’t think that is the issue. The issue might be something else
Any help trouble shooting it , any links , i did not have any issues with version 7 , same steps i took ?
@Mohammad We wanted to take look root cause and partner of issue and then we can resolve the issue.
where to start trouble shooting it ?
@Mohammad take look into log and add debugger into code.
which path captures the error log in?
from : /var/log/apache2/error.log this is what I have"
[Tue Aug 25 00:00:04.199589 2026] [mpm_prefork:notice] [pid 1447] AH00163: Apac>
[Tue Aug 25 00:00:04.199649 2026] [core:notice] [pid 1447] AH00094: Command lin>
[Tue Aug 25 00:53:55.392552 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:53:57.752482 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:53:58.388046 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:53:58.714553 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:54:00.762677 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:54:00.874322 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:54:00.979675 2026] [php:error] [pid 7017] [client…>
[Tue Aug 25 00:54:01.084526 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:54:01.189599 2026] [php:error] [pid 7017] [client …>
[Tue Aug 25 00:54:02.157137 2026] [php:error] [pid 7017] [client…>
[Tue Aug 25 00:54:02.268602 2026] [php:error] [pid 7017] [client…>
[Tue Aug 25 00:54:15.230576 2026] [ssl:error] [pid 7018] [client …>
[Tue Aug 25 01:17:31.532662 2026] [mpm_prefork:notice] [pid 1447] AH00170: caug>
[Tue Aug 25 05:28:45.341721 2026] [mpm_prefork:notice] [pid 1527] AH00163: Apac>
[Tue Aug 25 05:28:45.390167 2026] [core:notice] [pid 1527] AH00094: Command lin>
[Tue Aug 25 06:03:07.601135 2026] [mpm_prefork:notice] [pid 1527] AH00170: caug>
[Tue Aug 25 06:15:11.821448 2026] [mpm_prefork:notice] [pid 1531] AH00163: Apac>
[Tue Aug 25 06:15:11.836882 2026] [core:notice] [pid 1531] AH00094: Command lin>
I was able to get back the encrypted directory and mysql using Brady’s Fullbackup4.sh script and to restore from it , so this is up and running, same with my trusted duckdns certificate , that is also up and running, only problem is the lag , i hope if any help diagnosing it and fixing it , was never and issue with openemr 7
Mysql error log:
2026-08-25T09:28:49.081614Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.46-0ubuntu0.24.04.3) s>
2026-08-25T09:28:49.833019Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2026-08-25T09:29:06.414576Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2026-08-25T09:29:10.711836Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2026-08-25T09:29:10.711946Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encry>
2026-08-25T09:29:11.238248Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.>
2026-08-25T09:29:11.238436Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '>
2026-08-25T09:49:45.912060Z 8 [Warning] [MY-013360] [Server] Plugin mysql_native_password reported: ''mysql_nat>
2026-08-25T10:03:04.825872Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user . Shut>
2026-08-25T10:03:09.571259Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.46->
2026-08-25T10:15:15.786919Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.46-0ubuntu0.24.04.3) s>
2026-08-25T10:15:16.479842Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2026-08-25T10:15:30.436007Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2026-08-25T10:15:34.869241Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2026-08-25T10:15:34.869346Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encry>
2026-08-25T10:15:35.357604Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.>
2026-08-25T10:15:35.357859Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '>
2026-08-25T15:52:07.037054Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user . Shut>
2026-08-25T15:52:08.989226Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.46->
2026-08-25T16:01:52.339624Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.46-0ubuntu0.24.04.3) s>
2026-08-25T16:01:52.974270Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2026-08-25T16:02:08.318213Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2026-08-25T16:02:12.895108Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2026-08-25T16:02:12.895214Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encry>
2026-08-25T16:02:13.515282Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.>
2026-08-25T16:02:13.515480Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '>
2026-08-25T16:11:52.243127Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user . Shut>
2026-08-25T16:11:54.461775Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.46->
2026-08-25T16:24:16.264634Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.46-0ubuntu0.24.04.3) s>
2026-08-25T16:24:16.957935Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2026-08-25T16:24:32.113869Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2026-08-25T16:24:34.900444Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2026-08-25T16:24:34.900713Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encry>
2026-08-25T16:24:35.191831Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.>
2026-08-25T16:24:35.191998Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '>
2026-08-25T17:14:27.493378Z 8 [Warning] [MY-013360] [Server] Plugin mysql_native_password reported: ''mysql_nat>
In php.ini there is register_globals=off
when i searched for register_globals in my 8.3 php.ini i could not find it ??? why is that?
Hi @Mohammad
We despartly need your PHP error log here. Also monitor your browser console when logging in.
So after a login attempt grab and download /var/log/apache2/error.log and upload here.
Does login complete and if so are your still having slow performance?
Have you tried logging in through localhost i.e. https://localhost/openemr or whatever your path is?
What exact version of mysql and where you using mysql before upgrade?
This most likely will be an environment issue
re: You have run the sql_upgrade.php right?
Appreciate your help, thank you.
PHP 8.3 error.log:
[Wed Aug 26 00:48:02.942710 2026] [php:warn] [pid 40597] [client …] PHP Warning: Undefined>
[Wed Aug 26 00:48:02.942719 2026] [php:warn] [pid 40597] [client …] PHP Warning: Undefined>
[Wed Aug 26 00:48:02.942739 2026] [php:warn] [pid 40597] [client …] PHP Warning: Undefined>
[Wed Aug 26 00:48:02.942750 2026] [php:warn] [pid 40597] [client …] PHP Warning: Undefined>
[Wed Aug 26 02:11:05.818109 2026] [mpm_prefork:notice] [pid 40550] AH00170: caught SIGWINCH, shutting down gr>
[Wed Aug 26 12:57:58.883378 2026] [ssl:warn] [pid 1506] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 12:57:59.179780 2026] [ssl:warn] [pid 1533] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 12:57:59.190145 2026] [mpm_prefork:notice] [pid 1533] AH00163: Apache/2.4.58 (Ubuntu) OpenSSL/3.0>
[Wed Aug 26 12:57:59.190205 2026] [core:notice] [pid 1533] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Aug 26 14:43:41.635043 2026] [mpm_prefork:notice] [pid 1533] AH00170: caught SIGWINCH, shutting down gra>
[Wed Aug 26 14:45:10.704653 2026] [ssl:warn] [pid 1427] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 14:45:13.550238 2026] [ssl:warn] [pid 1507] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 14:45:13.560710 2026] [mpm_prefork:notice] [pid 1507] AH00163: Apache/2.4.58 (Ubuntu) OpenSSL/3.0>
[Wed Aug 26 14:45:13.560779 2026] [core:notice] [pid 1507] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Aug 26 14:46:11.386994 2026] [mpm_prefork:notice] [pid 1507] AH00170: caught SIGWINCH, shutting down gra>
[Wed Aug 26 15:55:25.102529 2026] [ssl:warn] [pid 1507] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 15:55:25.432107 2026] [ssl:warn] [pid 1529] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 15:55:25.445466 2026] [mpm_prefork:notice] [pid 1529] AH00163: Apache/2.4.58 (Ubuntu) OpenSSL/3.0>
[Wed Aug 26 15:55:25.445513 2026] [core:notice] [pid 1529] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Aug 26 16:01:43.170805 2026] [php:notice] [pid 1533] [client 127.0.0.1:55912] OpenEMR.CRITICAL: Uncaught>
[Wed Aug 26 16:12:04.980720 2026] [mpm_prefork:notice] [pid 1529] AH00170: caught SIGWINCH, shutting down gra>
[Wed Aug 26 16:34:53.725788 2026] [ssl:warn] [pid 1445] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 16:34:59.119974 2026] [ssl:warn] [pid 1474] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 16:34:59.140630 2026] [mpm_prefork:notice] [pid 1474] AH00163: Apache/2.4.58 (Ubuntu) OpenSSL/3.0>
[Wed Aug 26 16:34:59.140683 2026] [core:notice] [pid 1474] AH00094: Command line: ‘/usr/sbin/apache2’
[Wed Aug 26 17:31:55.130002 2026] [mpm_prefork:notice] [pid 1474] AH00171: Graceful restart requested, doing >
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set>
[Wed Aug 26 17:31:55.257574 2026] [ssl:warn] [pid 1474] AH01909: 127.0.1.1:443:0 server certificate does NOT >
[Wed Aug 26 17:31:55.260891 2026] [mpm_prefork:notice] [pid 1474] AH00163: Apache/2.4.58 (Ubuntu) OpenSSL/3.0>
[Wed Aug 26 17:31:55.260921 2026] [core:notice] [pid 1474] AH00094: Command line: ‘/usr/sbin/apache2’
log in completes with no errors
everything seems to function from tabs to add patient no errors except for the awful lag.
I was using mysql before the upgrade and it is :
mysql Ver 8.0.46-0ubuntu0.24.04.3 for Linux on x86_64 ((Ubuntu))
Both https://localhost/openemr
and https://@@@@@.duckdns.org/openemr will take me to the login page fast but once i put user name and log in it takes forever but eventually signs in.
I did not run sql_upgrade.php,
You def need to upgrade database from the version you are upgrading from e.g. 7.0.4 to 8.3.0.
From your browser run upgrade. Ref openemr upgrade document in downloads.
https://localhost/openemr/sql_upgrade.php
I did not migrate, i removed the old directory ( i have no copy of it) same with dependencies and fresh installed openemr 8
So this is a new database or did you import from your previous OpenEMR version?
a new database, not imported however i likely broke it keeping apache and mysql
then installed newer version of them broke something, however the certbot letsencrypt still works, same as duckdns with https, Brady’s script for encrypting and decrypting db and openemr tree is still working?
Yeah, I don’t know. Strange it’s login.
I replied to your P.M. Please check.
clean install 8.3.0 , addressing my dynamic IP with duckdns secured 443 with letsencrypt, Brady’s fullbackup4.sh writes encrypted daily to CD both directory and mysql data backups that can restore openemr is working like charm, speed is as it should be, npm /nodejs is working with ccda …cannot be happier.
Happy to hear all is well. You’ll see how much openemr has changed since the last time you used way back when.