Why I'm (now NOT) considering moving from OpenEMR to RxNT

I have been an OpenEMR user for about three years in my Internal Medicine clinic.

I’m seriously considering switching from OpenEMR to RxNT.

  1. Unable to migrate my database from v6.0.0 (4) → v6.1.0 (and beyond). I cannot use the “Backup-> Restore” mechanism – unable to import my backup on the v6.1.0 side. I am copying data from v6.0.0 to v6.1.0 tables because other mechanisms (Backup → Restore) and mysqldump and import fail (application because unresponsive with a white screen).
  2. No lab interfaces are available for the “docker” implementations of OpenEMR (I’m using AWS).
  3. Cost of AWS (around $600/month for me) - this could be optimized if I had a reliable migration pathway.
    I don’t want to leave OpenEMR, but I’m struggling.
    Sincerely,
    –Ralf

1. What RDS database are you using? MySQL? what version are you running?
I login in to the RDS in AWS and upgrade database there after obtaining the mysqldump file (learned this from you). Updating docker instances are just a ‘docker-compose up’ after changing the docker-compose.yaml file to what version I want to upgrade to and once , if you are using MySQL 8.0 as RDS, you really don’t have to worry about the database just docker compose up (I have not lost one EDI file or piece of patient infromation in the form of pdf, jpg,png, etc. I have not lost any data. Even if I made a mistake I can always repeat the steps and just change the docker-compose.yaml to a previous version and I have lost maybe 5-10 minutes. I have just had to re-mobilize customizations ( custom modules dependant on composer require are the biggest headaches for me because of github’s changes). The dockerized version of openemr has reduced my need significantly to go through all the painful safe guards of extensive back up procedures, ones that you have crafted that actually helped me understand some of the processes in the first place.

I change the standard openemr template to accompany the parameters of what I am upgrading to in terms of the database version if I had to launch a cloud formation in another region.

  1. What lab interface do you desire to see? Labcorp? Quest? I have been thinking of getting this added since dockerized openemr does not have this feature yet, at least not available for public consumption.
3 Likes

This also reduces downtime to 10-20 minutes if you stage customizations just outside the docker container.

2 Likes

I’m not sure a longer-term commitment to your AWS solution is the answer you want to hear, but if you haven’t looked at discount plans or reserved instances this might be a good time to – you can cut your costs by a /lot/.

I can’t help you with the upgrade issues, unfortunately.

1 Like

Excellent points. I will take a look at that. You’re right.
–RBL

1. What RDS database are you using? MySQL? what version are you running?

Identical for the v6.0.0(4) and v6.1.0 system
MySQL Engine version 5.7.33 General Public License.
Instance class: db.t3.medium vCPU 2. RAM 4 GB.

I’m not losing data … I just can’t access the data (webserver application). The webserver application does not work (white screen of death) if you just do a mysqldump and import the dump file into the new database. I am relegated to copying data table by table; this is a very tedious process.

2. I would like Labcorp and Quest. Neither one is available for the “dockerized” version of OpenEMR running on AWS (I investigated this about a year ago).

3. I really would like to make it to the 7.0.0+ versions. It’s overwhelming right now.

4. How do you stage customizations outside the docker container?

5. Also, I appreciate this open source product and all the developers. I would like to continue with OpenEMR. I’m just struggling to be a doctor and IT guy right now.

Adding new features is cool and sometimes required (ONC). A robust version-to-version migration path is also important, in my opinion.
–RBL

Hey Ralf, have you tried reaching out to any of the professional support vendors about this issue? I can PM people I would recommend if you haven’t tried anyone at this point. It seems like time is a scarcity for you right now and this would be something that I would think they could quickly get in and identify your white screen issue. It could just be an hour or two of their time to at least identify what is broken which can often be the hardest part.

At that point if it’s something broken in OpenEMR core we can look at getting a fix pushed out.

1 Like
  1. For the white screen of death, did you check sixa and sixb files where certs stored?Empty them so openemr can make new ones.
    /var/www/localhost/htdocs/openemr/sites/default/documents/logs_and_misc/methods
    rm sixa rm sixb
2 Likes

Yes. Please PM me a couple of names of professionals you would recommend.
–RBL

I tried the rm sixa and rm sixb. I had no luck.
–RBL

@adunsulag @Ralf_Lukner
I tried Ken but no joy. I’m talking to Dan now otherwise I don’t know of anyone else available.
I’m waiting for Dan to review the thread.

1 Like

Hi Ralph. I’m happy to help. I understand that these situations can be frustrating. Let me know how to get in touch with you. Thank you.

1 Like

Dan should get a hold of you. If he can’t help then I’ll at least see if I can’t help you get upgrade working though I don’t do docker that much. Still I’m pretty good at getting to the bottom of an issue!

1 Like

Log into DB Instance in AWS once you have your dump file.
Modify DB instance:

You likely have to connect the new database to the instance. You would have to retrieve the sql config php file and modify by placing the new rds endpoint. then reassign file permission back to apache.

Restablishing EC2 Connection to RDS;
/var/www/localhost/htdocs/openemr/sites/default —> modify sqlconf.php

sudo cp ‘openemr instance’:/var/www/localhost/htdocs/openemr/sites/default/sqlconf.php /home/ubuntu

1 Like

I am running 7.0 (1) on aws standard docker.

If you decided to run cloud formation-- modify OpenEMR-Standard.json and turn MySQL to 8.0
Sometimes, there are security group issues that can arise. Moreover, if you use route 53 /load balancers there can be some miscommunication at that level too.

1 Like

Leave customizations in /home/ubuntu directory use docker cp to move the customization to its location within the docker container. sh into the container to the mod locations and give permissions back to the apache root so openemr will handle them accordingly.

1 Like

@growlingflea moved me from AWS to GPC, and now I’m running without issues on 7.0.0(1) at about 2-3X the speed and roughly 1/3 the cost of what I had been paying on AWS.

I appreciate everyone’s help!
–RBL

4 Likes

Awesome! Congratulations!
Google Cloud Platform (GCP) or is it another one (GPC)?

1 Like