Upgrade Stuck from V6.1.0 to V7.0

Hello,

I was trying to upgrade my instance from V6.1.0 to V7.0 when i encountered this error. I’m unable to upload an image but this a text description of the error.

Stopping status checks. Csrf. No harm to upgrade and will continue
Authentication Error
End watching server processes for upgrade version UUID

The above error appears twice and stops the upgrade.

Currently running centos

Hi.
Make sure of the version you are trying to upgrade from. It is possible that you have version 6.0 instead of 6.1, try the migration selecting version 6.0

Hello @jfuenmayor,

I just changed it from 6.1 to 6.0 (as you instructed) and the error showed up again.

I would repeat the process . The7.0 tarball should be decompressed in the same directory you have the 6.1 version. Make sure you backup the whole database and directory. Then rename the old openemr-6.1 directory, usually is openemr and rename it to any name you want, ie. openemr_BAK. After this, rename the newly created openemr-7.0.0 directory directory to just openemr. I suppose you have also copied your old sqlconf.php file, the $config variable should already have been set to 1 but check it anyhow.

I have my openemr directory in /var/www/html/openemr, since I have a linux based installation and Apache. These procedures should be done as a superuser. The web script can be run from any computer. I recommend using the full name of your server instead of “localhost”, that is, instead of "http://localhost/openemr/sql_upgrade.php " use

 https://hostnameaddresss/openemr/sql_upgrade.php  

where hostnameaddress is the address of your server.

You should be able to query your system for its IP address.

Your problem can also be a matter of permissions. Make sure you use the -p option when decompressing the tarball. → " tar -pxvzf openemr-7.0.0.tar.gz"
I hope this helps.