Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Upgrade issue from 4.1.1 to 5.0.1

Hi All,
I have updated OpenEMR using openemr/sql_update.php, evrything went well.

But am not able to login any users.

I have tried running the below

  1. Open openemr/gacl/setup.php in web browser

  2. Open openemr/acl_setup.php in web browser

In the logs, I see

[10-May-2020 20:38:45 UTC] PHP Notice: Undefined index: basePath in D:\wamp64\www\openemr\library\core\src\Header.php on line 158
[10-May-2020 20:38:45 UTC] PHP Stack trace:
[10-May-2020 20:38:45 UTC] PHP 1. {main}() D:\wamp64\www\openemr\interface\login\login.php:0
[10-May-2020 20:38:45 UTC] PHP 2. OpenEMR\Core\Header::setupHeader() D:\wamp64\www\openemr\interface\login\login.php:101
[10-May-2020 20:38:45 UTC] PHP 3. OpenEMR\Core\Header::includeAsset() D:\wamp64\www\openemr\library\core\src\Header.php:76
[10-May-2020 20:38:45 UTC] PHP 4. OpenEMR\Core\Header::buildAsset() D:\wamp64\www\openemr\library\core\src\Header.php:119
[10-May-2020 20:38:46 UTC] PHP Notice: Undefined index: authUser in D:\wamp64\www\openemr\library\auth.inc on line 84
[10-May-2020 20:38:46 UTC] PHP Stack trace:
[10-May-2020 20:38:46 UTC] PHP 1. {main}() D:\wamp64\www\openemr\interface\themes\themeBuilder.php:0
[10-May-2020 20:38:46 UTC] PHP 2. require_once() D:\wamp64\www\openemr\interface\themes\themeBuilder.php:12
[10-May-2020 20:38:46 UTC] PHP 3. include_once() D:\wamp64\www\openemr\interface\globals.php:574
[10-May-2020 20:38:46 UTC] PHP Notice: Undefined index: authProvider in D:\wamp64\www\openemr\library\auth.inc on line 84
[10-May-2020 20:38:46 UTC] PHP Stack trace:
[10-May-2020 20:38:46 UTC] PHP 1. {main}() D:\wamp64\www\openemr\interface\themes\themeBuilder.php:0
[10-May-2020 20:38:46 UTC] PHP 2. require_once() D:\wamp64\www\openemr\interface\themes\themeBuilder.php:12
[10-May-2020 20:38:46 UTC] PHP 3. include_once() D:\wamp64\www\openemr\interface\globals.php:574

Please advise

hi @yousufttp, you could reset the admin password to pass

UPDATE users_secure SET password = ‘$2a$05$MKtnxYsfFPlb2mOW7Qzq2Oz61S26s5E80Yd60lKdX4Wy3PBdEufNu’, salt = ‘$2a$05$MKtnxYsfFPlb2mOW7Qzq2b$’ WHERE username = ‘admin’

also can use suggested php settings to get rid of notices in the error log