Upgrade failure 5.0.1 failure


(Robert Rovner) #1

I waited about 10 months to upgrade to 5.0.1 cause I knew things could not go right. Sure enough, these are the error messages that popped up when I tried to log in after the upgrade and the patch-6.

Error: Unknown column ‘version’ in ‘field list’

/var/www/openemr/library/log.inc at 55:sqlInsertClean_audit
/var/www/openemr/library/authentication/login_operations.php at 113:newEvent(login,docrovner,Default,1,success: 192.168.1.124)
/var/www/openemr/library/auth.inc at 47:validate_user_password(docrovner,Default)
/var/www/openemr/interface/globals.php at 574:include_once(/var/www/openemr/library/auth.inc)
/var/www/openemr/interface/main/main_screen.php at 25:require_once(/var/www/openemr/interface/globals.php)
Did I not validate my password?
Thanks for any help.

Robert Rovner


(Jerry P) #2

Did ya run admin.php or sql_upgrade.php after upgrade? Even if so try to run again.


(Robert Rovner) #3

Thanks for the advice. Do I run that in Terminal or in a web browser? And what is the address for the web browser if I use that?

Robert


(Jerry P) #4

https://www.open-emr.org/wiki/index.php/Linux_Upgrade_5.0.0_to_5.0.1
Important that your sqlconf.php is duplicated from old version to new so you don’t get a setup openemr dialogs.
If not on localhost then use whatever domain you have setup to access openemr for your site.


(Stephen Waite) #5

hi @Robert_Rovner, if this is the ubuntu/debian package see this https://www.open-emr.org/wiki/index.php/Ubuntu_Package_Upgrade_to_5.0.1_with_PHP7


(Jerry P) #6

Thanks Stephen,
Main thing is to run sql_upgrade.php again because version column in audit is new to v5.0.1


(Robert Rovner) #8

Please tell me the command to run sql_upgrade in ubuntu terminal. I tried “php” but this only brought up the file.


(Robert Rovner) #9

I ran “php sql_update.php” and this errored. It says that I have an invalid index (HTTP HOST} at line 107 in my “globals.php” file. This is getting rather complicated.

Rovner


(Robert Rovner) #10

Stephen, I tried to dpkg the update for 5.0.1 for Ubuntu 6.x.x first, and this ran for a few minutes before I realized my mistake. Then I executed dpkg for the update for Ubuntu 7.x.x and above. Perhaps this mixed files from different updates into the system? At any rate, I cannot re run the update, and I can’t run sql_update as it says that I have an undefined file in my globals.php file. If you have some time, could you help me over the phone?

Robert


(Robert Rovner) #11

sjp,

I ran admin.php from localhost, but I still cannot log in. Any other thoughts? I cannot access my files. I am not sure where to get my old sqlconf.php to plug it in, and into which folder should I place it?

Doc Rovner


(Jerry P) #12

Robert, was trying to get you to get to and run sql_upgrade.php from your browser. From admin.php UI, what happened?


(Robert Rovner) #13

Success is mine! I wiped out everything and established a clean disc and server and reloaded the patient data Not as elegant as solving the problem but much quicker


(Stephen Waite) #14

nice @Robert_Rovner, please keep that backup handy in case there’s some other data that will need to be imported down the road