Updating 4.2.2 - 5.0.1 databases


(Donna Robinson) #1

Hello. I have had to make a fresh install of XAMPP, Apache, MySQL etc. on a new device and have a backup of the old 4.2.2 files. I have followed the steps to install the 5.0.1 version of OpenEMR, but now need to copy the patient data, prescriptions etc. (I’m just the IT Intern) over to the new version. What specific files do I need to copy over? I have already copied over sites/default/documents and the others from the “upgrading 4.2.2 - 5.0.0” but they have not copied over the data.

Thank you.


(Stephen Waite) #2

hi @Medconsult, try the upgrade guide, https://www.open-emr.org/wiki/index.php/Windows_Upgrade_5.0.0_to_5.0.1


(Donna Robinson) #3

Hi Stephen. I have done that already, including copying over the files " openemr/sites/default/documents
openemr/sites/default/edi
openemr/sites/default/era
openemr/sites/default/letter_templates"

What else do I need to copy across? I have done all of the steps in the ‘upgrading from 4.2.2 to 5.0.0’ and ‘upgrading from 5.0.0 to 5.0.1’ wiki pages.


(Stephen Waite) #4

hi @Medconsult, do you have the old xampp directory? That’s where the database lives.