Unble to register API client

Trying to register a new API client through postman. I’m able to POST to the server, but the endpoint /default dir in oauth2 doesn’t exist. Since the endpoint to register is /oauth2/default/registration, my POST fails and I’m not able to register a new client.

I’m using OpenEMR version 6.0.2

I’m using: Firefox

Operating System
I’m using: Linux ( Ubuntu 20,.04)

Logs to not pertain to this issue

Are you running in a multi-site environment?

The registration URL is setup to be a virtual mapping with the url being as follows: https://<openemr_url>/oauth2/<site_parameter>/registration. That site parameter is typically set to default if you are not running in a multi-site environment. The parameter maps to the value defined in your site configuration which is defined in your <openemr_installation_directory>/sites/ folder.

If you are able to post the full request / response from PostMan we can probably give you better support here. The endpoint should exist if this is a default installation. If its a multi-site you’ll need to use your site parameter id that corresponds to the site installation. You will likely find more help in your logs if you turn on the debug logs in your global logging settings.

We were able to get certificate It was a permissions issue.

  Now we are getting errors pertaining to scope giving a syntax

error when generating

authentication token with password grant flow.

What scopes are you sending? Again posting a copy of the Postman Request/Response will be helpful as its difficult to figure out what error you are running into from the descriptions are you providing.

If English is not your native language you can also post in your native language as we have various users who speak different languages here that can also provide support.

We have tried sending all scopes. And yes, English is as native to me as it can be. sometimes I write a bit cryptic to save space. It is not a language issue. We are trying to migrate .pdf files to documents but this is where we are stuck.

Finally we were able to solve the problem. We are still not quite sure as of to what really happened, but after updating the system, it worked as it is supposed to with the same scopes we were using. That is strange since I regularly update the system. Thanks for the help.

In the AWS Standard version, where would we find this /sites/ folder?

look inside the openemr docker