Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Unable to run make inside the openemr docker container

I am currently trying to add custom forms to openemr and have followed the form instructing how to do so. However, when I go running the command make INFILE= inside the docker container it says it has no command make. But apt, apt-get, and yum are not installed. How do I run make inside a docker container?

hi @Timothy_Reitz, what instructions are you following?

@stephenwaite I am following the direction in this link:

https://www.open-emr.org/wiki/index.php/OpenEMR_Xml_Form_Generator

I have openemr running in a docker container and MySQL in another container. When I enter the container using docker -it sh and try to run the make command it does not recognize that command.

ok @Timothy_Reitz, have you looked into layout based forms? A whole lot of work over the past couple years by @sjpadgett :heart:

@stephenwaite I will look into that but we are trying to make a very custom form and need the format to be a pdf. Do you know of any way to run that make command or install it in docker?

it’s prob running alpine so checkout apk package manager

@stephenwaite That worked! I was not filmilar with apk just yum, apt, and apt-get. Thank you for your help.

1 Like