UB04 support - wkhtmltopdf not working

billing

(Julie Buurman) #1

Situation
It seems that wkhtmltopdf is not working with alpine. I can get it to install if I add gcompat to the docker file and change the permisions for the file (wkhtmltopdf64-linux) however I then run into the next error of QSslSocket: cannot resolve CRYPTO_num_locks. From the research I have done it seems that wkhtmltopdf64 needs to be upgraded? any idea on how to get this working again? I have checked on the demo to see if it’s just me and I’m getting the same error there.

OpenEMR Version
I’m using OpenEMR version 5.02

Operating System
I’m using: Ubuntu 18.10 - Docker

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability

The exit status code 127 says something went wrong: stderr:sh: 1: /var/www/html/openemr/vendor/openemr/wkhtmltopdf-openemr/bin/linux/wkhtmltopdf64-linux: not found stdout: `` command: /var/www/html/openemr/vendor/openemr/wkhtmltopdf-openemr/bin/linux/wkhtmltopdf64-linux --lowquality --grayscale --margin-bottom0in--margin-left0.19in--margin-right0.19in--margin-top0.15in--orientationPortrait--page-sizeLetter--no-outline --print-media-type --zoom1.045--keep-relative-links/var/www/html/openemr/sites/default/documents/temp/knp_snappy5dc51b17afbe49.39603996.html`


(Stephen Waite) #2

hi @Julie_b, looks like @sjpadgett brought this in with a nice readme, GitHub - openemr/wkhtmltopdf-openemr: Dependencies for wkhtmltopdf support in OpenEMR


(Julie Buurman) #3

Hi @stephenwaite. I saw that thank you. I have followed it. However version 1.2.4 will not run with Alpine or any newer versions of linux - at least from my reasearch. Version 1.2.5 is needed. However the repo for h4cc wkhtmltopdf has been abondoned(will find a link when I’m not on my phone) ? I tried to get this working all day. Got it running with install from APK add wkhtmltopdf. And changing the code to point to the local binary. However the output is all wrong. Idk - if someone could look at it and see if I’m right? Or am I spinning myself around.