Step 3: Configuring OpenEMR Error


(Barry Mclean) #1

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\openemr\library\classes\Installer.class.php on line 599


(Brady Miller) #2

hi @Luopean ,

Ensure you have appropriate PHP settings set, which can find here:
https://www.open-emr.org/wiki/index.php/FAQ#What_are_the_correct_PHP_settings_.28can_be_found_in_the_php.ini_file.29.3F

Also, on windows, recommend using the xampp/openemr package (php settings are already set):
https://www.open-emr.org/wiki/index.php/OpenEMR_5.0.1_XAMPP_Package_Installation


(Barry Mclean) #3

Thank you, I opted for the XAMPP Installation bundle. Its way much easier! I don’t seem to have the option for adding new patients though. I need to have a patient record on my DB for me to work out my learning. I have followed the manual but I’m still stuck


(Stephen Waite) #4

have you tried clearing the cache in your browser?


(Barry Mclean) #5

Yes, I have, but this is all I get. I have accessed the demo site and I can see the ‘add patient’Screenshot_1 option easily available


(Stephen Waite) #6

and this is when you click on Patients->New/Search?


(Barry Mclean) #7

Yes> I don’t have the Add new Option


(Barry Mclean) #8

I just did a clean install, and I’m all good now, thank you. Your support response time is AWESOME!!!