SNOMED RF1 installs but is not integrated

installation
question

(Pete Boyd) #1

I am having trouble getting SNOMED RF1 to work, can anyone see why please? Thanks in advance.

I have this package from nlm.nih.gov:
SnomedCT_RF1Release_US1000124_20160901.zip

The OpenEMR documentation says:

“Note that since OpenEMR 4.1.2, you can also install the SNOMED US Extension Pack after you install the SNOMED International Pack. You first install the International pack, then remove it from the contrib/snomed directory. Then you place the US extension pack in the contrib/snomed directory and install it.”

…where as the SNOMED copy I have says this:

“The US Edition of SNOMED CT is a combination of the full SNOMED CT International Release and the US Extension to SNOMED CT.
The US Edition eliminates the need for implementers to manually combine the US Extension and the International Release.”

It imports OK using Administration > Other > External Data Loads > SNOMED

https://www.open-emr.org/wiki/index.php/Code_Types says:
“A code type can be configured or added at Administration->Lists->‘Code Types’ .”

“Code Types” does not exist on that page. There is however “Code(s)”. Selecting that does not offer SNOMED in the drop-down list. It does have ICD9 Diagnosis and ICD10 DIagnosos.

It is the same with Administration > Codes: there is ICD9 and ICD10 but no SNOMED.

No SNOMED in here either:
Patient/Client > Patients > select a patient > Recurrent Appointments: Edit Medical Problems > Add >
Type:
Active Issue Codes:
Coding:

I have tried Administration > Lists > Code Types > check “Active” & uncheck “Hide”

Is this of any concern in the log?:

[PHP Notice: Undefined variable: code_type_name_external in /var/www/html/interface/patient_file/encounter/superbill_custom_full.php on line 643, referer: https://www.homelesshealthlink.com/interface/patient_file/encounter/superbill_custom_full.php

Thanks


(Brady Miller) #2

Hi @PeteBoyd ,
What OpenEMR version are you using?
To confirm, were you not able to see the following list:
Administration->Lists->Code Types


(Pete Boyd) #3

OpenEMR 5.0.1 (6)

There is no “Code Types” at Administration > Lists. There’s a “Code(s)” heading in the far right of the table / form in that page:
“ID / Title / Order / Default / Active / Type / Notes / Code(s)”

Otherwise I’m not sure where I’m supposed to see a “Code Types” list on that page.

Thanks @brady.miller


(Brady Miller) #4

The Administration->Lists page looks like so:

And can then type in code types to get the list:

And will then look like so:


(Pete Boyd) #5

This is so helpful, thank you! I’ve enabled SNOMED now (at least, I’ve ticked the boxes to do so).

The OpenEMR documentation says to follow Administration > Lists > Code Types when in my opinion it should say Administration > Lists > Code Types > List Editor > Code Types.


(Brady Miller) #6

Hi @PeteBoyd ,
Some other good news on the SNOMED front is that OpenEMR 5.0.2 (plan release in about 2 months) will support RF2:


(CG) #7

Do we know which SNOMED data files the importer currently supports?
I’ve tried SnomedCT_USEditionRF2_PRODUCTION_20190301T120000Z.zip , and SnomedCT_InternationalRF2_PRODUCTION_20190131T120000Z.zip, neither works.
I also tried reverting to SnomedCT_USEditionRF2_PRODUCTION_20180901T120000Z.zip from last year just to see if it was something new in how the source data files were formatted, but it’s not able to work with that file either.