RxNorm on web server

Tried to install RxNorm on web server. Install goes on for hours, but doesn’t work. When reloading external data loads page, install option reappears.

During installation, folder and files are created under server’s /.cagefs/tmp directory. Complete zip is uploaded to this directory and files extracted within minutes.

ICD10 installation works (within minutes), and when doing same process on local machine rather than web server, works as well. Tried RXCUI installation through native data loads as well but doesn’t accept monthly release zip or RRL files.

OpenEMR Version
I’m using OpenEMR version 6.1.0

I’m using: Firefox

Operating System
I’m using:

no logs

see this post, also might have to increase php settings post_max_size and upload_max_filesize

Thank you. For those who encounter same problem, available documentation not up to date so here’s what you should do:

  1. change post max and upload max to 80M (otherwise, you might get the “loading successful, 0 new, 0 updates” message after uploading RXnorm
  2. in open emr, admin\forms\lists
  3. manage lists drop down field, choose code types
  4. change RXCUI to active (otherwise, you’ll get “no active code set” message when trying to upload RXnorm)
  5. download monthly zip as instructed
  6. admin\coding\native data loads
  7. upload zip
1 Like

updated the wiki

1 Like

thank you for the post. These steps worked perfectly.