Raspberry pi docker install issues

Situation
Blank screen after install

OpenEMR Version
I’m using OpenEMR version 6.0.0

Browser:
I’m using: safari

Operating System
I’m using: rasbian lite

Logs
Did you check the logs? Yes seems to be running
Was there anything pertinent in them? Not that I could tell

‘’’Love OpenEMR? You can now support the project via the open collective:

Contribute to OpenEMR - Open Collective

Starting cron daemon!
Starting apache!
AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using 172.24.0.3. Set the ‘ServerName’ directive globally to suppress this message‘’’
Any help would be appreciated and thanks in advance.
This is the example code I’m trying to get running.

# Use admin/pass as user/password credentials to login to openemr (from OE_USER and OE_PASS below)
# MYSQL_HOST and MYSQL_ROOT_PASS are required for openemr
# MYSQL_USER, MYSQL_PASS, OE_USER, MYSQL_PASS are optional for openemr and
#   if not provided, then default to openemr, openemr, admin, and pass respectively.
version: '3.1'
services:
  mysql:
    image: linuxserver/mariadb
    container_name: Openemr_mysql
    restart: unless-stopped
    volumes:
      - databasevolume:/var/lib/mysql
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=America/New_York
      - MYSQL_ROOT_PASSWORD=root
      - MYSQL_USER=openemr
      - MYSQL_PASSWORD=openemr
      - MYSQL_DATABASE=openemr
      - Character_set_server=utf8mb4
#    command: ['mysqld','--character-set-server=utf8mb4']
    
  openemr:
    restart: unless-stopped
    image: openemr/openemr:6.0.0
    container_name: Openemr
    ports:
    - 82:80
    - 442:443
    volumes:
    - logvolume01:/var/log
    - sitevolume:/var/www/localhost/htdocs/openemr/sites
    environment:
      MYSQL_HOST: 
#      MYSQL_PORT_3306_TCP_ADDR: mysql
#      MYSQL_PORT_3306_TCP_PORT: 3306
      MYSQL_DATABASE: openemr
      MYSQL_ROOT_PASS: root
      MYSQL_USER: openemr
      MYSQL_PASS: openemr
      OE_USER: admin
      OE_PASS: pass
#      Server_Name: 712.16.0.2
    depends_on:
    - mysql
volumes:
  logvolume01: {}
  sitevolume: {}
  databasevolume: {}

There’s some problems with this, yes. Please check openemr-devops/raspberrypi at master · openemr/openemr-devops · GitHub in general and https://github.com/openemr/openemr/blob/master/docker/production-arm/docker-compose.yml in particular for specifics.

1 Like