Psychiatry Set


#1

mangaleshjoshi wrote on Wednesday, February 27, 2013:

Hi!

I am trying to set up psychiatry forms using Psychiatry Set but getting the following error. (The same error also comes for some other forms too…will list and post in the same thread).:

ERROR: could not open table.sql, broken form?

Kindly help.
Regards,
MJ :slight_smile:


#2

bradymiller wrote on Thursday, February 28, 2013:

Hi MJ,

The contrib directory is in need of a serious clean up. There was a discussion in the weekly conference call several weeks ago to begin removing broken forms etc. and I think the psychiatry set should be on that list; from my memory those forms had some incomplete functionality also (regarding the autosaving).

I think Art and Tony were planning to remove some of the outdated/broken forms. If so, lets add the psychiatrySet to the list.

Please post the other forms where you are seeing this error and also let us know your OpenEMR version.

thanks,
-brady
OpenEMR


#3

sunsetsystems wrote on Thursday, February 28, 2013:

I’d hate to throw away knowledge or code that may be useful some day.  Let’s make a point of making them easy to get, and telling people how to do that.

Rod
www.sunsetsystems.com


#4

juggernautsei wrote on Thursday, February 28, 2013:

I agree with Rod on this one to keep the forms because someone may take them up and update them.

MJ,

How did you get the error message you received?
You might want to check the table.sql file to update ENGINE=MyISAM to  ENGINE=InnoDB.

Also remove them from the psychiatrySet folder and place the individual folders in the forms directory.
They should run correctly after doing these things.

Let me know if you have any more questions.

Sherwin
openmedpractice.com


#5

sriniemr wrote on Thursday, February 28, 2013:

MJ,

Sherwin is correct,Place all forms in individual folders,then  try to access it by one by one,

Hope it helps

Please let me know,If need any code fix

Srini
seenu4043@gmail.com


#6

mangaleshjoshi wrote on Thursday, February 28, 2013:

Hi Guys,

Thanks for the prompt replies. I actually copied Psychiatry Set folder from contrib/forms to interface/forms. Then I registered the same from Administration/Forms option. And then when I click of Install DB, I get the given error under Forms Administration. So what is the reason and the solution? BTW I am using v4.1.1(10)

Thanks in advance.
MJ :slight_smile:


#7

mangaleshjoshi wrote on Thursday, February 28, 2013:

Hey I got it friends. As Sherwin suggested, after copying subfolders to the forms, it worked. Thanks a lot Sherwin and all.
Regards,
MJ :slight_smile:


#8

sriniemr wrote on Thursday, February 28, 2013:

Mj,

Here is my responses

You need to copy & paste the below three folder from openemr/contrib/psychiatrySet into openemr/interface/forms

1.brief_aan_verwijzer

2.intakeverslag

3.psychiatrisch_onderzoek

FYI : These forms are not using the security model

Hope this helps

Thanks
Srini
seenu4043@gmail.com


#9

mangaleshjoshi wrote on Thursday, February 28, 2013:

Thanks Srini, I got it.
Regards,
MJ :slight_smile:


#10

blankev wrote on Thursday, February 28, 2013:

This seems to be an orriginal Dutch (Leemhuis?) contribution. If there is a wish for translation please let me know and I will give it a try……

Or we could make a reverse translation Google document ???


#11

hitechelp wrote on Friday, March 01, 2013:

If there is a way to import and export layout based forms we will contribute our set of psych forms in LBF.
They were developed for use with a smartphone or tablet but they work great on the big screen too.


#12

Has anyone tried to use psychiatrisch_onderzoek on OpenEMR 5.0. It seems to be broken after upgrading. Does anyone have any tips to diagnose or an error log location to look at?


#13

Hi @petersmm ,

Likely related to this issue(see bottom of that thread for solution):

-brady
OpenEMR


#14

Hello Brady,

I moved jquery.js to the folder openemr\library\js as suggested. However, the problem is still not resolved. It seemed like it was working, once I refreshed the cache, however, do I need to restart the OpenEMR? What other things can i look into? I am not seeing anything abnormal in the javascript console in FF or in Chrome just the normal //@ that was discussed in the thread. Also, I did not see a $ is not referenced error to begin with as I looked through before I read this thread. I see echo ‘lalala 2’. Thoughts?


#15

Actually, when I think about it, would make sense to copy the current version of this from contrib dir into your interface/forms dir (since we have been updating the forms in contrib with the code changes). Assuming you haven’t customized what is in interface/forms.
If still not working, then recommend looking at the php error log and see if anything shows up there when you try to open the form.
-brady


#16

I have not customized the forms and have already copied them from psychiatry set folder. Still to no avail. What’s weird is the autosave is working and it is returning with lalala2 on the way back (which I saw in the code). Nothing recent in the error logs about errors with the forms or anything else for that matter. Thoughts?


#17

Is there anyway for me to push out the SQL statement to a debug and then try to insert them into the DB manually?


#18

New update: I have discovered that it seems Chrome cannot save to that form and Firefox does not. How can I collect valid debug information to further narrow the issue? Thoughts?


#19

Hi @petersmm ,
Just tried out these 3 psych forms (note they all appear to need to be installed to work). On firefox i see the forms fine, but there is definitely weirdness in whether things are saved or not. Appears to not saving correctly on new forms, but then saves when edit it.
-brady