Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Openemr express plus ssl AWS

Hello

I have Openemr express plus running but ran into a problem. Firefox gives a warning because there is no security. How can I get Https to work and the security certificate in the browser.

Please guide me through the process I am new at this. Any suggestions related to this topic is welcomed

Thanks

hi @jackel7, try let’s encrypt

The docker by default will have a self-signed certificate for SSL use. To have a signed certificate, rec either placing it in the docker or set up let’s encrypt use in the docker or use the let’s encrypt feature in the docker (per above link).

I am trying to figure it out now. I am learning CLI. what is the fastest way to navigate to the file.

The certificate/key is stored at /etc/ssl/certs/webserver.cert.pem and /etc/ssl/private/webserver.key.pem in the docker. And on aws can set only https to connect and not allow http. I think there is also a comment that you can uncomment in apache openemr.conf to also enforce this openemr-devops/openemr.conf at master · openemr/openemr-devops · GitHub

Thanks Brady Millier

is this the same for openemr express plus. I have no Idea how to implement the changes. I have the aws cli running now. where do I run this in what file or folder.
I am very new at this but willing to learn if good directions are given

I am trying to get this inside docker. I did the Super User and got into the directory lightsail… but now this is a part that I would like more clarity on

edit docker-compose.yml: add environment variables DOMAIN and EMAIL to the openemr container

./docker-compose up -d

Thanks

vi /root/openemr-devops/packages/lightsail/docker-compose.prod.yml

you’ll add the domain and email like below

environment:
      MYSQL_HOST: mysql
      MYSQL_ROOT_PASS: password
      MYSQL_USER: mysqluser
      MYSQL_PASS: mysqlpass
      OE_USER: username
      OE_PASS: password
      DOMAIN: yourdomain.com
      EMAIL:  email@somehost.net
    links:
    - mysql

Hi Stephen

Is the vi the tool that you mentioned to me earlier?

if so where can I get it

yes, vi is available in the minimal ubuntu environment, you can search the web for a vi video tutorial

you can install other editors too so it’s not so minimal after all

Hey Stephen

I did what you the steps but still still no lock. Is there any other things that I should do also after adding the domain and email?

Thanks

sorry this should have been

cd /root/openemr-devops/packages/lightsail/
vi docker-compose.prod.yml
./docker-compose up -d

Hello Stephen

Am I to delete the swp file that was done and start over because message E325: ATTENTION Found a swap file by the name “.docker-compose.prod.yml.swp”

hi @jackel7, sure thing

also, ‘docker-compose’ is not currently installed.

I read that docker is not Hippa-eligible.

Here is the system recommendation after I ran
apt install docker-compose
Recommended packages:
docker.io
The following NEW packages will be installed:
docker-compose python-backports.ssl-match-hostname
python-cached-property python-docker python-dockerpty
python-docopt python-functools32 python-jsonschema
python-texttable python-websocket python-yaml
0 upgraded, 11 newly installed, 0 to remove and 36 not upgraded.
Need to get 505 kB of archives.

Is this only going to deal with the ssl portion or all of the docker package

sorry, it’s

./docker-compose up -d

edited the above post too

I did all that was stated and now I put my instance ec2 address in the browser and it took me to the Apache2 Default page?

I dont know what happen to the instance

it may take a moment to pull itself together
try

docker ps

and then insert the openemr container id in the following

docker logs <openemr containerid>

is this container ID the instance ID? Not for sure