Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

OFFSITE Portal Registration problem

rickzimm wrote on Thursday, April 14, 2016:

Hi Zh Healthcare

I installed openemr 4.2.1 with new database on a virtual private server from a webhoster “De Heeg” in the Netherlands. After the successful installation, I went to administrations and portal and clicked the “enable offsite portal” option. I filled in the registration form, received the activation code by email, did the activation procedure, and was directly redirected to: https://old.mydocsportal.com/login.php?error=2. When filling in the Provider id, username and password the error appears: Invalid Provider Id.

My settings:

  1. Offsite Patienten Ingang Site adres: https://mydocsportal.com/provider.php
  2. Patient portal setting for admin: active

After saving, there appeared the Patient portal option in the left nav menu, but on clicking it showed a page with INVALID USER NAME OR/AND PASSWORD.

As adviced in topics, tried to set up a openVPN, however …
Try to establish a openVPN, the only information I miss, is in the vpn configuration files.

  1. I’m not able to open the portal account, so not able to download through the portal the info.
  2. In the OpenEMR at Administration->Globals->Portal->“Download Offsite Portal Connection Files” it shows “offsite portal web service fails”.

Please, kindly check out the issue!

Note: I didn’t received an email with the registration details!

zhhealthcare wrote on Friday, April 15, 2016:

Hi Rick,

We checked our portal connectivity using OpenEMR 4.2.1 version. We couldn’t find any issue in the connectivity. Can you please give me some more details regarding the issue like your provider id, practice name. Are you using windows or linux server for hosting OpenEMR?

Thanks & Regards
ZHHealthCare

rickzimm wrote on Saturday, April 16, 2016:

Hi ZH Healtcare,

Thank you for yor response.

  • Provider ID: mannenkliniek
  • Practice name: Mannenkliniek de Boer
  • The webserver where I installed OpenEMR: Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0-fips. PHP Version 5.3.24 and system Linux vps.

If you want I could give you the login information to our openEMR? Preferably, sent via a more private email connection.

Thx, Rick

blankev wrote on Saturday, April 16, 2016:

Beste Rick de Boer, als je hier en daar foute vertaling in het Nederlands tegenkomt, laat me dan weten, dan kan ik het in de originele vertaal-tabellen veranderen. Daarna is het gebruik van de nieuwe vertalingen en het downloaden van de vertalingen een handigheidje, maar heel makkelijk.

Ik ben niet meer zo actief met het installatie proces dus kan je niet helpen bij de installatie, maar je hebt goede hulp. Het komt goed. Paar keer heen en weer en het is duidelijk.

Mochten er meer collegas geinteresseerd zijn in Nederland, dan is dat leuk om te horen en kunnen we misschien door goede samenwerking OpenEMR nog beter maken.

Het is een gratis programma, maar van hoge kwaliteit. Om alle opties te vinden, moet je soms wat spitten en soms ook kleine veranderingen aanbrengen. OpenEMR is tot op de punt en de komma te veranderen, naar eigen smaak.

Groeten uit Curacao, huisarts P.W. Blankevoort

zhhealthcare wrote on Monday, April 18, 2016:

Rick,

We couldn’t find any provider id “mannenkliniek” registered in our system. Can you please clear the Username, Password and Provider ID from GLOBALS and try to register once more.

Thanks & Regards
ZHHealthCare

rickzimm wrote on Monday, April 18, 2016:

I cleared from GLOBALS and register again. Unfortunately the same result:

  1. directly redirected to: https://old.mydocsportal.com/login.php?error=2. When filling in the Provider id, username and password on the webpage, the error appears: Invalid Provider Id.
  2. In the openemr app; filled the new register information in GLOBAL-> PORTAL. After saving, there appeared the Patient portal option in the left nav menu, but on clicking it showed a page with INVALID USER NAME OR/AND PASSWORD.

Any clue?

Thx, Rick

Note: used:

  1. Provider ID: mannenkliniek
  2. Practice name: Mannenkliniek de Boer

zhhealthcare wrote on Tuesday, April 19, 2016:

Rick,

Can we have a screen sharing session so that we can have a better idea on how you are doing the registration process. Please let me know your available time.

Thanks & Regards
ZHHealthCare

zhhealthcare wrote on Tuesday, April 19, 2016:

My email id is vinish@zhservices.com. You can send me a mail.

Thanks & Regards
ZHHealthCare

rickzimm wrote on Tuesday, April 19, 2016:

I just emailed you the necessary information.

Thx, Rick

rickzimm wrote on Tuesday, April 19, 2016:

Hi ZH Healthcare,

Thank you guys for helping me out. It works … it seems that the problem was an invalid provider ID

Thx for the great service.

Rick

rickzimm wrote on Wednesday, April 20, 2016:

Hartelijk dank voor je reactie. Het opstarten kost even wat tijd, maar dan heb je ook wat!

Goed om te weten dat een vertaalslag goed te doen is, tot nu toe ziet de vertaling er up-to-date uit.

Ik ga er eerst mee aan het werk.

MVG, Rick

blankev wrote on Friday, April 22, 2016:

Rick op de een of andere manier werkt de reply via je vorige bericht niet op mijn W10 instrallatie.

Je kan een e-mail sturen naar pimmblankevoort AT hotmail DOT com zonder spaties.

Dit antwoordde ik:

Rick,

ik heb nooit echt serieus via de “patient portal” gekeken wat er allemaal te downloaden is. Maar ik denk wel dat het mogelijk is. Ook via de mogelijkheid van Wordpress die door Rod Roark is ontwikkeld (had iets te doen met Nina turtle software). Dat is niet makkelijk, maar wel heel interessant om verder te onderzoeken. Daar kan je ook door de patient zelf in te beantwoorden vragenformulieren ontwikkelen die de patiënt kan invullen waardoor ze automatisch door OEMR worden opgenomen met de basis gegevens na accordering van de specialist.

Gr, Pimm

Hi Issue with openemr ZH healthcare portal connection. I am getting the following error message when i check chkk.con

  1. Check Offsite UserName And Password Stored In Administration->Globals->Portal
  2. Enable soap extenion in php.ini file
  3. Check Your Domain Name Or IP Address (OpenEMR should host in a static IP Or Dedicated Domain Name. Patient Portal Not Support localhost or internal IP)
  4. Check your site ID(Patient portal registed site folder and openemr site folder should be same.)

please help
srikanth

Hi ZH healthcare

I am trying to setup offsite portal but there seems to be multiple problem with the VPn. Do we need VPN now? If yes, which version of VPN is needed?
Kindly help with the connection of the offsite portal. Thanks

Dr. Arnab Naha