Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

No longer able to log into production system - Site ID is missing from session data!

Situation
No longer able to log into production system (Webserver) - “Site ID is missing from session data!”
After doing manual backups of the production system, it is no longer possible to log into the web server. I can still ssh to the EC2 instance.
To correct the situation, I stopped and restarted the EC2 instance. Clearing browser caches had no effect.

OpenEMR Version
I’m using OpenEMR version 5.0.2(5)

Browser:
I’m using: Chrome or Safari - no difference

Operating System
I’m using: AWS Ubuntu

Logs
Did you check the logs? Checking them now

You’ve not given enough info to tell whether this is simply the message you receive when you’re logged out, so check that’s not the case: go to the web address for the front page of your OpenEMR and see if you get the login page.

I did get the login page, but then it would show the Site ID missing from session data when I tried to log In Clearing the cache and cookies did not help, rebooting the web server did not help, rebooting the RDS did not help. Not until I stopped and restarted the EC2 instance was I able to get the calendar and usual screens that come after you log in. Sorry, I had to figure out how to get this working in the middle of the night. In terms of potential provoking conditions, I had done a mysqldump, which did not seem to be the problem and then attempted to (zip)tar the OpenEMR directory of the web server ran, out of disk space temporarily before deleting the gzip file. I also was accessing other OpenEMR web servers in other regions of AWS (trying to set up a test system to test migration from 5.0.2(5) to 6.0.0 with a 35 GB database.

Hi Ralf,
Are getting any authentication errors in your logs?
If so, try deleting sites/default/documents/logs_and_misc/methods/sixa and sixb

1 Like

The issue was running out of disk space (found this in the error.log). access.log had grown to a huge size. Deleted it and everything started working again. This issue is that when OpenEMR cannot write to access.log (due to inadequate disk space or whatever), it will not proceed and display the ‘Site ID is missing from session data!’ error.
–RBL

1 Like

I spoke too soon. It looks like the problem is back. The access.log file isn’t even there. Any other suggestions? I tried renaming sites/default/documents/logs_and_misc/methods/sixa and sixb … made no difference. Next moved them into an old_files directory and rebooted the web server. That worked.