Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Need to update ICD 10 codes - Suggestions needed

Hi All,

We haven’t updated ICD 10 codes in our system since 2017

So what are the steps needed for importing all data. I see in https://www.cms.gov/Medicare/Coding/ICD10/index.html there are 2018,2019 and 2020 versions released

how to import all these version codes in to our system.

Please guide

And what are the database tables names which contain all ICD 10 and SNOMED codes.

hi @dorareddys, if you are running 5.0.2.1 (first patch installed) then you can move the 2020 files in and the 2019 files out of the contrib/icd10 folder and then import through admin->other->external data loads after you load the checksums into the supported_external_dataloads table

@stephenwaite
Thanks for your reply.

We have not updated our ICD 10 codes since 2017, is it ok to just update to 2020 files.

hi @dorareddys, yes, if you’re running 5.0.2.1.

@stephenwaite Thanks for the reply.

We haven’t updated code since 2017 So copying library/standard_tables_capture.inc from openemr 5.0.2.1 into our system is sufficient for upgrading icd 10 or do i need to copy any other files?

Please suggest.

hi @dorareddys, probably be fine but never hurts to test on a development system first :slight_smile:

the development system can also be a great way to test your backup and restore process, not to mention the upgrade, lots of new stuff since 2017 :slight_smile:

1 Like

Thanks @stephenwaite for prompt responses.

Let me understand on upgrading 2020 ICD 10 more clearly.

Step 1: Download and Copy these 2 files 2020-ICD-10-CM-Codes.zip and 2020-ICD-10-PCS-Order.zip and place it in contrib folder.

Step 2: need to place below 2 scripts in upgrade file and run them
#IfNotRow4D supported_external_dataloads load_type ICD10 load_source CMS load_release_date 2019-10-01 load_filename 2020-ICD-10-CM-Codes.zip
INSERT INTO supported_external_dataloads (load_type, load_source, load_release_date, load_filename, load_checksum) VALUES
(‘ICD10’, ‘CMS’, ‘2019-10-01’, ‘2020-ICD-10-CM-Codes.zip’, ‘745546b3c94af3401e84003e1b143b9b’);
#EndIf

#IfNotRow4D supported_external_dataloads load_type ICD10 load_source CMS load_release_date 2019-10-01 load_filename 2020-ICD-10-PCS-Order.zip
INSERT INTO supported_external_dataloads (load_type, load_source, load_release_date, load_filename, load_checksum) VALUES
(‘ICD10’, ‘CMS’, ‘2019-10-01’, ‘2020-ICD-10-PCS-Order.zip’, ‘8dc136d780ec60916e9e1fc999837bc8’);
#EndIf

Step 3: Copying library/standard_tables_capture.inc from openemr 5.0.2.1 into our system

Step 4: Goto External Data Loads and Select ICD 10 and Run Upgrade button.

I’m i missed anything or Good to go. Please suggest.

hi @dorareddys, step1 should also remove the 2019 files

1 Like

@stephenwaite ok.

Few more questions on ICD 10 codes

  1. What are Billable ICD 10 codes? All codes from 2020-ICD-10-CM-Codes.zip are billable? and 2020-ICD-10-PCS-Order.zip are non-billable codes?
  2. Is ICD 11 codes also released? If Yes Where can they available?

Thanks for all your help.

ICD-10-CM is used to justify procedure codes like CPT used in US billing

while the other file quoting from CMS “The ICD-10-PCS is a procedure classification published by the United States for classifying procedures performed in hospital inpatient health care settings.”

ICD-11 are released but there is no official US version yet

1 Like

It seems that the 2020 files in master don’t have all the codes. I can’t find P04.81, which a customer was looking for.

Hi @growlingflea, that was a new code in the 2019 set but it’s also in the 2020 files. Just used external data loads on the demo farm :cow2:

Maybe I did this wrong. I downloaded the 2020 files from master branch in github:

I moved them into my contrib folder. Previously there were files from 2018. This is OpenEMR-501

image

I put the following in the phpmyadmin console:

#IfNotRow4D supported_external_dataloads load_type ICD10 load_source CMS load_release_date 2019-10-01 load_filename 2020-ICD-10-CM-Codes.zip
INSERT INTO supported_external_dataloads (load_type, load_source, load_release_date, load_filename, load_checksum) VALUES
(‘ICD10’, ‘CMS’, ‘2019-10-01’, ‘2020-ICD-10-CM-Codes.zip’, ‘745546b3c94af3401e84003e1b143b9b’);
#EndIf

#IfNotRow4D supported_external_dataloads load_type ICD10 load_source CMS load_release_date 2019-10-01 load_filename 2020-ICD-10-PCS-Order.zip
INSERT INTO supported_external_dataloads (load_type, load_source, load_release_date, load_filename, load_checksum) VALUES
(‘ICD10’, ‘CMS’, ‘2019-10-01’, ‘2020-ICD-10-PCS-Order.zip’, ‘8dc136d780ec60916e9e1fc999837bc8’);
#EndIf

Then went to External Dataloads and I received confirmation that the files are correct.

Then when I go to the search, this code does not show anything for the specified code:

something went wrong, you’ll have to remove the 2020 entry from standardized_tables_track and redo after making code changes in library/standard_tables_capture.inc 2020 I10 dx update with a work around for nested folder (#2630) · stephenwaite/openemr@53b8ae6 · GitHub

So this will work with 501 too?

sure, the code change is to handle the nested folder in the 2020 cms icd zip file

I followed the instructions here and it made all the older ICD10 codes disppear. Codes were unavailable via the billing and WMT modules. I re-tried the procedure again and then all ICD10 codes were unavailable but some of the tables were visible from phpmyadmin. I ended up having to copy all the ICD10 tables from a backup database and put them in the live database to get the codes back. Now its working as it did before the upgrade attempt. I’m wondering if there is a step that I missed?

I am working with a copy of 501, and we have the files from 2018. Do I need to install the 2019 first, then the 2020 codes? From what I read it wasn’t necessary for 502, but would it be necessary for 501?

Thanks!!

hi @growlingflea, no, you can go straight to 2020 since it loads the whole new set not incrementally.

@stephenwaite I’m getting 500 internal server error When i click upgrade.
Followed the same steps. Attached the screenshot for reference.

I’m using PHP version 5.6.31.

hi @dorareddys, what openemr version are you running?