Read about OpenEMR's Response to the COVID-19 Pandemic at https://www.open-emr.org/covid19/

Missing "Layout-Based Forms" list in 5.0.1?

I’m currently using a new install of v5.0.1(6). I’m building a new form in layouts, but, I cannot find the “Layout-Based Forms” option in the Administration=>Lists area in order to add the new layout to the registered/unregistered forms list. Am I missing something? Thanks for the help.

It seems a new Layout Based Forms tab populates automatically along with “Administrative” and “Clinical” in the patient forms section. This resolves my issue. Thanks!

Hello
I have the same problem.
But I don’t understand your solution.
please provide more details.
Thanks.

do you mean looking under Admin->Layouts for LBFs?

I’m having the same issue with the Layout Based Forms missing from Administration>Lists. I see the Administration>Layout option but I clicked the box to make a form inactive so that no one would use it while I was working on it. Now it’s not visible with the other (active) layouts and I can’t find it anywhere to even make it active to keep working on it.

@DJDean3,
Active checkbox under Layout Properties determines the LBF forms are Active/Inactive. Currently if the form is inactive, form name will be removed from the dropdown list under Administration ->Layout.
To make it active, a small code change is required in the file - interface/super/edit_layout.php
Under function named collectLayoutNames remove AND grp_activity = 1 from query. Now you can find the form name and make it active again.

Thanks,
ViSolve

2 Likes

I removed "AND grp_activity = 1 from interface/super/edit_layout.php but it didn’t work. It’s worth noting that the root file is “open_emr_web_backups” so I’m not sure if there’s a specific step I need to take to make my small change active or if it just didn’t work.

Thank you for your help!

It seems inappropriate to completely take a form out of play by inactivating it, and not allow it to be reactivated by the reverse operation. This takes the control of the LBF out of the hands of the user who may have created it, and puts it in the hands of a developer, which the user or the EMR administrators may not have access to. And if the user can’t make that little code change, s/he has simply lost that LBF.

Just saying.

@DJDean3 ,
The solution we proposed is just a work around fix to display the inactive forms in the dropdown.
We have attached the screenshot of how the fix works for the form named “Sample Form”. Kindly check and share your views.

@htuck,
We agree with your views. There is an usability issue here - where currently there is no UI available to activate an inactivated LBF form.

Our suggested improvement (requires customization) in usability will be:

  • On selection of “Administration->Layouts”, Layout Editor will be opened.
  • An “Inactive” checkbox could be included.
  • By default the Edit select drop down will have only Active forms
  • On selection of Inactive checkbox, the edit select box will drop the values of both Active and Inactive forms with some color differentiation.

So that it will provide a way for users to activate the form.

Thank You
ViSolve-120

EDIT: Please ignore this reply, I had mistakenly edited a backup of the EMR instead of the actual EMR files. Thank you again for your help!

Apologies for the late reply.

Unfortunately, the fix you suggested doesn’t seem to have worked if you happen to know of an alternative. A screenshot is included of the edited file.