Log in error message


(Thomas Herchline) #1

Situation
Describe your problem here: When I enter the user name and password, I receive the following error message:

ERROR: insert failed: insert into log ( date, event, user, groupname, success, comments, crt_user, patient_id) values ( NOW(), ‘login’,‘admin’,‘Default’,‘1’,‘success: ::1’,NULL,NULL)

Error: Duplicate entry ‘155867’ for key ‘PRIMARY’

C:\xampp\htdocs\openemr\library\log.inc at 39:sqlInsertClean_audit
C:\xampp\htdocs\openemr\library\authentication\login_operations.php at 116:newEvent(login,admin,Default,1,success: ::1)
C:\xampp\htdocs\openemr\library\auth.inc at 50:validate_user_password(admin,Default)
C:\xampp\htdocs\openemr\interface\globals.php at 352:include_once(C:\xampp\htdocs\openemr\library\auth.inc)
C:\xampp\htdocs\openemr\interface\main\main_screen.php at 25:require_once(C:\xampp\htdocs\openemr\interface\globals.php)

OpenEMR Version
I’m using OpenEMR version 4.2.1

Browser:
I’m using: Chrome

Operating System
I’m using: Windows 10 Home

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability


(Sherwin Gaddis) #2

Has the program worked before getting this error?


(Thomas Herchline) #3

Yes. We have been using it for 3 years now.

It sounds like something related to SQL, but I don’t know enough about SQL to know how to fix it.

TH


(Sherwin Gaddis) #4

Are you on windows or linux? Are you running local or in the cloud?


(Thomas Herchline) #5

Windows, local. Very limited internet access with the computer OpenEMR is installed on.


(Sherwin Gaddis) #6

Do you have windows updates turned on or off? I am going to assume you are using Xampp. Can you attach your log file.


(Daniel) #7

Have you been able to resolve this? Was anyone playing around in myPHPAdmin? Someone might have changed a setting on the table. Also, the id should be the primary key. If you need help with this I’m happy to assist you.

When you look at the log table using phpMyAdmin make sure the id is set to AutoIncrement


(Thomas Herchline) #8

I do not have access to the computer at this moment. I’m certain windows update is off - the computer is rarely connected to the internet.

I should have access to the computer tomorrow.

No one else would have changed any settings. I am the only one who does more than enter patient information.


(Sherwin Gaddis) #9

Ok, at this point, I am going to ask to reboot the server first and try and log in again. If you receive the same issue, then we will try another route. Was this a it worked one day and then the next day it did not?


(Thomas Herchline) #10

Correct - worked one day and not the next. Rebooting has not fixed the problem.

Don’t know if it is related to the problem, but when I turn the (laptop) computer on, there is an error message about the charger is incorrect And the battery does not charge.

Unfortunately, today is my last day in country (Jamaica); there is another physician coming in tomorrow. I will pass along whatever suggestions you have.

Thanks for your help!


(Stephen Waite) #11

sounds like OpenEMR crashed during an insert to the log and wasn’t able to increment the sequences counter. Should be fairly easy to fix if can open phpmyadmin and delete the offending record or increment the counter but there may be more than the log table affected. Also sounds like need a new battery and/or charger


(Thomas Herchline) #12

How do I find/delete the offending record?

TH


(Stephen Waite) #13

do you have phpmyadmin under Admin->Other->Database?


(Thomas Herchline) #14

I am no longer in Jamaica, but I will forward these messages to the physician taking over.

Thank you