Locked out with "Site ID is missing from session data!" message (AWS deployment)


(Peter Stein) #1

Situation
I believe this began after a sleep-wake cycle on my Macbook. If so, I had a CAMOS-type encounter form open when the computer went to sleep. When I woke it up and returned to the Chrome tab that had been running OpenEMR, it switched to a full blank screen with just that error message. Since then I have been unable to log in. The only result is that message.

I noticed this dreaded message has come up under a variety of other circumstances, and I couldn’t tell if any previous solutions apply here. But can someone advise on a next step?

I’m back in clinic tomorrow, so am hoping there’s an easy solution for this one!
Thanks,
Peter

OpenEMR Version
I’m using OpenEMR version: 5.0.1 AWS Cloud, micro instance

Browser:
I’m using: Chrome 73

Operating System
I’m using: Mac OSX 10.10

Logs
Did you check the logs? Was there anything pertinent in them? Paste them here (surround with three backticks (```) for readability NEVER BEEN SURE WHERE TO FIND THAT (I’m not a pro user)


(Stephen Nielson) #2

@peter.stein Have you tried clearing your cache and browser cookies? That should resolve the issue. You can verify if its a browser cookie problem by trying to login using Safari on your macbook, or trying Chrome from a different browser.


(Peter Stein) #3

Just solved–beginner’s mistake of pasting in URL from my address bar, which is different from the public DNS address. Sorry for false alarm!