Installation problems with Ubuntu 16.4


(Tyran Mincey) #1

Hello there;
Happy new year and long time no speak

I have had a few problems getting up and running. I have been using EMR since 2012 successfully so I needed to update from 4.2.1 to 5.0.1 and the application did not work it loaded but could not find the databased and give an error after the log screen. So I tried to update ubuntu to 16.4 as I was running 14… Well it crashed when I got to the part when the mysql password was requested and after 10 hours I ended up having to start a fresh installation. I did back up and I can see the original files are on the old server drive. Now that I have this new application set up I am running Ubuntu 16.4, apache is installed and confirmed as is mysql; however when I installed via the WGETs link nothing happens - the file downloads and then when I install it is says that is happening but when I check www directory there is no openemr file and when go to the web address there is no "Not Found
The requested URL /openemr was not found on this server.


(Henry Alvarez) #2

Hi Tyran,
I run Ubuntu via a VMware player. Look up 4.1.2-7 Upgrade to 4.2.0 left sidebar absent.
When you upgrade from one Openemr version to another you must use the exact same openemr version. In other words you install the Ubuntu 16, then install the same version of openemr that you were using. Then you restore the data from your old version. Then you can upgrade your openemr version. The Ubuntu upgrades have never worked for me.

Good luck,
Henry


(Tyran Mincey) #3

Hello Henry;

From root and hom folders I have tried downloading 4.2.1. The file downloads in both .deb and and gzipped but when I run dpkg or apt-get install. I get the following errors;

"unable to locate package openemr _4.2.1_all.deb

couldn’t find and package by glob…"

When I try to install by iunzipping the tarball I get "gzip:stdin: not in gzip format
tar:child returned status 1
tarL error is not recoverable:exiting now
Any thooughts?
Thanks
T


(Henry Alvarez) #4

Hi
Use cmd line and install from here;
If there are errors follow the instructions in the wiki.
This occurs almost every time.
https://www.open-emr.org/wiki/index.php/OpenEMR_4.1.2_Ubuntu-Debian_Package_Installation

Then follow the steps I posted in the forum.
Make sure version and patch is the same as your currently using before to restore.
Once you have 4.2 upgrade, then you should be able to do a cmd line openemr upgrade. The problem your encountering is due to the php change that occurred at that time.

Hope this helps,

Henry


(Tyran Mincey) #5

Hi there - I gave it another shot. I guess what is not clear because it says the directories are bing created but when it i finishes there are none. Do I need to install from the" www" directory or from root -I am installing from root right now and I do see a file now - “index.html” but when search using locate - I do not find any openemr fiies or directories


(Tyran Mincey) #6

Hello again;

I started from the begininng and reinstalled everything. I then used command line and follow this instructions. I was able to down the .deb fiile, issued the command for dpkg and I received an error. Then I used the apt-get install -f and got lost of activity and it looked like it was working. The were not appatent errors and I typed url in and it took forever and gave an error - “site cannot be reached” took to long to respond. What is next?


(Tyran Mincey) #7

Also Henry I am just thinking. should be running php in an an earlier very as now I am running php 7?