ICD-10 2019 "Unsupported database load file"


(Henry Alvarez) #1

Hi,

Trying to update the ICD-10 codes. The CMS site says there are no GEMS files. What am I doing wrong.

This is what the Export Database Import Utility screen says;

Staged Releases

2018-ICD-10-CM-General-Equivalence-Mappings.zip

2018-ICD-10-Code-Descriptions.zip

2018-ICD-10-PCS-General-Equivalence-Mappings.zip

2018-ICD-10-PCS-Order-File.zip

UNSUPPORTED database load file:
2019-ICD-10-CM-Code-Descriptions.zip!

UNSUPPORTED database load file:
2019-ICD-10-PCS-Order-File.zip!

Thank you,

Henry


(Stephen Waite) #2

the supported_external_dataloads table needs the md5 hashes of the 2 new zip files, see this sql insert statement


(Henry Alvarez) #3

Hi Stephen,
I’m running 5.0.1-6. Do you mean that I need to copy the green areas ( including insert to) into each of their respective files?

Thank you,
Henry


(Henry Alvarez) #4

And change line 28 in the php.version file from 262 to 263


(Stephen Waite) #5

think all you’ll need is to run the 2 mysql insert commands, can you get to a mysql prompt?


(Henry Alvarez) #6

I use webmin or ubuntu cmd line to access the system. Is there a separate cmd prompt for the database? No problem inserting those lines of codes in those files thru webmin.


(Stephen Waite) #7

try this from the cmd line

mysql -u [username] -p[password] [dbname] -e “INSERT INTO supported_external_dataloads (load_type, load_source, load_release_date, load_filename, load_checksum) VALUES (‘ICD10’, ‘CMS’, ‘2018-10-01’, ‘2019-ICD-10-CM-Code-Descriptions.zip’, ‘b23e0128eb2dce0cb007c31638a8dc00’); INSERT INTO supported_external_dataloads (load_type, load_source, load_release_date, load_filename, load_checksum) VALUES (‘ICD10’, ‘CMS’, ‘2018-10-01’, ‘2019-ICD-10-PCS-Order-File.zip’, ‘eb545fe61ada9efad0ad97a669f8671f’);”


(Henry Alvarez) #8

Hi Stephen,
Do you first;
~$ mysql -u [username] -p [dbname]
mysql >
Then input;
-e INPUT INTO …

Sorry mysql cmds are new to me.
Am I mistaken that the commit that you pointed to meant that these were code lines to add to those 2 files?
Trying to understand what is being done.

Thank you,

Henry


(Stephen Waite) #9

hi @hamd, it’s all one command, you can put your password right up against the -p like
-ppassword, just edited the post above


(Henry Alvarez) #10

Hi Stephen,
Tried the cmd above and got the following;
-bash: syntax error near unexpected token ‘)’

Is it possible instead to insert those lines into the file sql/database.sql at lines 7150 and 7151 without using cmd line as you showed above?
That would be very easy for me to do.

Thank you,

Henry


(Stephen Waite) #11

hi @hamd, whoops, try this file, you will probably have to change username password

sup_ext_dat_load.txt (488 Bytes)


(Henry Alvarez) #12

Hi Stephen,
Still no go.
Tried the cmd you suggested and get the following;
mysql : [Warning] Using a password on the command line interface can be insecure.

Does this mean that the cmd should be done from root (#) ?
Thank you
Henry


(Stephen Waite) #13

pretty sure that means it worked :slight_smile:


(Henry Alvarez) #14

Hi Stephen,
Yes it changed Unsupported next to each the 2 files to the below.

There is no visible “UPDATE” button visible.
What is happening ?
Thank you,
Henry


(Henry Alvarez) #15

Stephen,
I looked into the sql/database.sql file and do not see any change that has occurred. Looks like the below;

Not sure what is going on. Did I not update the previous external dataloads updates
correctly ?
(PS, Finally learned how to take a screenshot and put it into the forum.)
Thank you,
Henry


(Henry Alvarez) #16

Double checked and the contrib/icd10 directory has all the files as shown below;

I have made all these changes on a appliance copy to be sure it all works out all right before working on the production appliance, just in case.
This method has served me well.

Thank you,
Henry


(Stephen Waite) #17

hi @hamd, it won’t update the script just the database. If you remove the 2018 files from contrib/icd10 you should be able to proceed


(Henry Alvarez) #18

Hi Stephen, how do I confirm that the 2018 update has been done? It’s saying that the latest install is the 2017. If that’s so, shouldn’t I remove the 2019 files, update the 2018, then put the 2019 files back in and update to 2019? Is there a file that shows what the latest update is?

Thank you,

Henry


(Stephen Waite) #19

if it says it’s 2017 then that is active in the system. It depends if you have old dates of service prior to 10-1-18 that might need the older version but most likely you can go straight to 2019.


(Henry Alvarez) #20

Hi Stephen,
It worked!!!
Learned 5 things.

  1. When External Database Import Utility “Installed Release” reads that the release date is 2017-10-01; It really means it’s the 2018-ICD-10 codes are loaded.
    Likewise when it reads that the release date is 2018-10-01; It really means that the 2019-ICD-10 codes are loaded.

2)You can’t have 2 different code dates loaded in the contrib/icd10 file. It won’t let you update.

3)The mysql cmd file does require
“-p[password]” as you indicated.

  1. “Staged Releases” means; These are the files sitting in the contrib/icd10 file. It doesn’t mean that they have or have not been loaded into your system.

  2. When the Staged Release box says “the installed version and the staged files are the same”; It means exactly that, i.e. the files in the Staged Release (contrib/icd10 file) are already loaded into your system.

Thank you so much for your help!!
You and the OpenEMR team are truly incredible!!!

Henry