HTTP ERROR 500 on new Installation

I was trying to install OpenEMR on a domain, but once installation done on step 3 , got HTTP ERROR 500
on log I found this

Line 726: - - [09/Sep/2023:07:16:13 -0400] "GET /openemr/interface/login/login.php?site=default HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/116.0.1938.69" "-"
" "-"

site URL:

Have you tried this:

Try deleting sites/default/documents/logs_and_misc/methods/sixa and sixb then clear browser and login.

Hope this helps

1 Like

Listen delete those two keys as a last resort .
Those two files should stay with the current database version and if they are deleted and while they are regenerated any passwords that are used in globals will have to be re-entered.
This isn’t true for login passwords. That uses a different encryption. So I just want to warn everybody to use the delete method sparingly.

1 Like

Thanks for the heads-up. I tried this as your instruction, but still not worked.
But now the error is different, took too long to respond

Note: Database: Type and version
MySQL 5.7
Note2: Again , old 500 error :frowning:

Which OS is your server running ?

You were running step 2 right at the initial setup ?
Could you please tell me your OS and type of server (AWS EC2 perhaps?). I have just installed a server from scratch on EC2, Ubuntu 22.

1 Like

2nd stem went ok.
Using Linux, shared hosting on IONOS

Could you start again, you can follow this guide : Clean install on EC2 Ubuntu 22.04

Hi Earid A.earid,
Could you please check host name,databse credtials that it is correct in sites/default/sqlconf.php file.
you can follow below link for OpenEMR Linux Installation