Formating header spaces

billing

(Sherwin Gaddis) #1

We got a message from Availity that the header information was incorrect. The bottom one is the original header for claims. The top one is what they requested the header be changed to the right order for them.

They wrote today to say that the spacing is incorrect. There should be 5 spaces after the sender ID ZZ030240928 there are 6. There should be 6 spaces after the 30AV09311993 there are 5.

I have tried to find what formats the header data. I thought it was the edi.inc file.
I changed the line but nothing moved. So, now I am stumped as to where to look for what formats the output.

@stephenwaite @brady.miller @MatthewVita @visolveemr


(Stephen Waite) #2

hi @juggernautsei, is this 5.0.1?


(Sherwin Gaddis) #3

Yes it is 5.0.1(7).
and I have to type more so that I can reply.


(Stephen Waite) #4

this shouldn’t require any coding and should all be configurable under admin->practice->X12 partners but interface/billing/billing_process.php has the code


(Sherwin Gaddis) #5

@stephenwaite
You mentioned that it should be configurable from the globals. I can move the numbers but the globals can’t move the ZZ and the 30. Those are fixed position. Unless I am missing something in the globals that would move those as well. Could you please share with me how?


(Stephen Waite) #6

hi @juggernautsei, you can set it based on these values


(Sherwin Gaddis) #7

Good Morning! @stephenwaite

I looked at what you showed me and changing the setting will not change the location of the information. They want the sender ID to come first in the header. Then the receiver ID next. Changing Receiver ID Qualifier (ISA07) only changes the ZZ to something else but does not change the fact that it is the receivers ID.


(Stephen Waite) #8

switch ISA06 and ISA08 in the X12 config