Do you use or administer OpenEMR? Take the General Satisfaction Survey to help improve the product

Fee sheet list numbering

Since upgrading from 5.0.1 to 5.0.2 or 6.0.0. I have noted the fee sheet presets do not retain the numbers added Administration -> List -> Fee Sheet.

Is there a fix or work around.

hi @dahalday, could you share a screenshot of your list->fee sheet please?

Thanks for your reply
See attached

take item 012 in established pt -annual, in fee sheet 501 it’s shown as 2 but in fee sheet 600 it’s shown as 12, that looks like an improvement

Thanks but the greater issue is that after upgrading from 5.0.1 to 6.0.0 the fee sheet display was adjusted.

With 501 will number 01. 02. 03. 04. 05. 06. 07. 08. 09. 10. 11. 12. 13. etc

However in 600 the numbering will be 1 2 3 4 5 6 7 8 9 0 1 2 3 … so there are are no double digit numbers just 1 through 0 then repeat. this is also reflected under the tabs Miscellaneous > Black Forms > Superbill/Fee Sheet the numbering could be off.

Also I noted what I consider very vexing with versions 5.0.2 and 6.0.0 :
Under the tabs Administration > Forms > Lists > Fee Sheet if you adjust the fee sheet
example 1. From 1 To 40 Showing items: 40 of 197 which shows by default instead of
example 2 . From 1 To 197 Showing items: 1 - 197 of 197 depending your setup , After an upgrade for example if you make any adjustment to the Group options in example 1. showing From 1 To 40 then save all the data after 40 is lost in the billing fee sheet and has to be reentered or reimported.

If you make adjustment with example 2 From 1 to 197 then all the data with the adjustments would be saved.

Please let me know if there is a work around.

so is the screenshot above of the fee sheet misnamed Fee sheet preset 501?

The top one is 6.0.0 showing numbering 1 to 0 then 1 to 4

Then bottom one is 5.0.1 showing number 01. to 14. for the selected sheet before the upgrade.

ok, thank you, so this is a bug, will file it and start work on it soon

Very much appreciated. Thank you.

here’s the old code and here’s when it was changed

a quick fix would be to change $cleave_opt to 1 for your sitch in the v6 file

Thanks changing to the old code worked for me. many thanks.