Failure during database access! Check server error log error message


(Richard Torres) #1

Situation

I get that error on 5.0.2 after upgrading a db from 5.0.1. This message appears if you type the correct user/password. If you type an incorrect you get the normal Invalid username or password.

OpenEMR Version
5.0.2

Browser:
IE, Chrome, Firefox (all current)

Operating System
I’m using: Windows Server 2016 (Host)
Clients Windows 10 1903

Logs
Assuming the error log is error.log

[Thu Oct 31 13:13:18.671994 2019] [php7:notice] [pid 6300:tid 1780] [client ::1:58332] PHP Notice: Undefined variable: forwardIp in C:\xampp\htdocs\openemr\library\sanitize.inc.php on line 31, referer: http://localhost:81/openemr/interface/login/login.php?site=default

[Thu Oct 31 13:13:18.680994 2019] [php7:notice] [pid 6300:tid 1780] [client ::1:58332] PHP Notice: Undefined index: password_max_failed_logins in C:\xampp\htdocs\openemr\library\authentication\login_operations.php on line 196, referer: http://localhost:81/openemr/interface/login/login.php?site=default

[Thu Oct 31 13:13:18.732960 2019] [php7:notice] [pid 6300:tid 1780] [client ::1:58332] Executing as user:openemr Statement failed:UPDATE users_secure SET login_fail_counter = 0 WHERE BINARY username = ?:Unknown column 'login_fail_counter' in 'field list'==>C:\xampp\htdocs\openemr\library\authentication\login_operations.php at 118:resetLoginFailedCounter, referer: http://localhost:81/openemr/interface/login/login.php?site=default

I’ve tried twice to create a blank DB and import a backup copy from current 5.0.1 db and same result each time. Any ideas what could be causing this?