Failed to open PHP error (Solved)


#1

Hello I’m using Mint 19.1 and I have installed OpenEMR on another computer and it worked. Now this is another computer with Mint 19.1 and after I installed it did not open.

The only thing I did different was installed another program Yetiforce, and I had to edit the Php, apache for it to work with yetiforce.

How could I get both program to work.

Apache

  • Added
    ServerTokens Prod
    ServerSignature Off

  • Modify
    <Directory /var/www/>
    AllowOverride All

Apache error log is below

[Sat Jun 22 22:56:45.857242 2019] [php7:warn] [pid 8588] [client 127.0.0.1:55762] PHP Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

[Sat Jun 22 22:56:45.857282 2019] [php7:error] [pid 8588] [client 127.0.0.1:55762] PHP Fatal error: Unknown: Failed opening required ‘/var/www/openemr/setup.php’ (include_path=’.:/usr/share/php’) in Unknown on line 0

Mysql

  • Added to mysqld.cnf
    character-set-server = utf8
    collation-server = utf8_unicode_ci
    innodb_lock_wait_timeout = 600

Mysql error log
Version: ‘5.7.26-0ubuntu0.18.04.1’ socket: ‘/var/run/mysqld/mysqld.sock’ port: 3306 (Ubuntu)
2019-06-23T03:51:52.377103Z 2 [Note] Access denied for user ‘openemr’@‘localhost’ (using password: YES)
2019-06-23T03:56:36.189842Z 7 [Note] Access denied for user ‘openemr’@‘localhost’ (using password: YES)
2019-06-23T04:07:23.111873Z 16 [Note] Access denied for user ‘openemr’@‘localhost’ (using password: YES)

Solved Have to enable opcache.save_comments = 1